summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--INSTALL33
-rw-r--r--INSTALL.rst19
-rw-r--r--MANIFEST.in2
-rw-r--r--README.rst2
4 files changed, 21 insertions, 35 deletions
diff --git a/INSTALL b/INSTALL
deleted file mode 100644
index 3af722f..0000000
--- a/INSTALL
+++ /dev/null
@@ -1,33 +0,0 @@
-Installation
-------------
-pyOpenSSL uses distutils. Use setup.py to install it in the usual way:
-
- $ python setup.py install --user
-
-Or use pip:
-
- $ pip install --user .
-
-You can, of course, do
-
- $ python setup.py --help
-
-or
-
- $ pip install --help
-
-to find out more about how to use these tools.
-
-Documentation
--------------
-
-The documentation is written in reStructuredText and build using Sphinx.
-
-To build the text, html, postscript or dvi forms of the documentation, this is
-what you do:
-
- cd doc
- # To make the text-only documentation:
- make text
- # To make the dvi form:
- make dvi
diff --git a/INSTALL.rst b/INSTALL.rst
new file mode 100644
index 0000000..eea013b
--- /dev/null
+++ b/INSTALL.rst
@@ -0,0 +1,19 @@
+Installation
+============
+
+To install pyOpenSSL::
+
+ $ pip install pyopenssl
+
+If you are installing in order to *develop* on pyOpenSSL, move to the root directory of a pyOpenSSL checkout, and run::
+
+ $ pip install -e .
+
+
+Documentation
+=============
+
+The documentation is written in reStructuredText and built using Sphinx::
+
+ $ cd doc
+ $ make html
diff --git a/MANIFEST.in b/MANIFEST.in
index 8137258..31cf021 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,4 +1,4 @@
-include LICENSE ChangeLog INSTALL README TODO MANIFEST.in OpenSSL/RATIONALE
+include LICENSE ChangeLog INSTALL.rst README TODO MANIFEST.in OpenSSL/RATIONALE
recursive-include doc *
recursive-include examples *
recursive-include rpm *
diff --git a/README.rst b/README.rst
index 5b9f507..1f795de 100644
--- a/README.rst
+++ b/README.rst
@@ -2,7 +2,7 @@
pyOpenSSL - A Python wrapper around the OpenSSL library
------------------------------------------------------------------------------
-See the file INSTALL for installation instructions.
+See the file INSTALL.rst for installation instructions.
See https://github.com/pyca/pyopenssl for development.