summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini6
1 files changed, 2 insertions, 4 deletions
diff --git a/tox.ini b/tox.ini
index 60a15ce..da54916 100644
--- a/tox.ini
+++ b/tox.ini
@@ -3,15 +3,13 @@ envlist = pypy,py26,py27,py32,py33,py34
[testenv]
deps =
- setuptools>=7.0
+ setuptools>=7.0 # older setuptools pollute CWD with egg files of dependencies
coverage
- pytest
setenv =
# Do not allowed the executing environment to pollute the test environment
# with extra packages.
PYTHONPATH=
-# The standard library unittest module can run tests on Python 2.7 and newer
commands =
python -c "import OpenSSL.SSL; print(OpenSSL.SSL.SSLeay_version(OpenSSL.SSL.SSLEAY_VERSION))"
- coverage run --branch --source=OpenSSL -m pytest OpenSSL
+ coverage run --branch --source=OpenSSL setup.py test
coverage report -m