summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorptmcg <ptmcg@austin.rr.com>2023-04-08 11:58:24 -0500
committerptmcg <ptmcg@austin.rr.com>2023-04-08 11:58:24 -0500
commit4054216260f8f0c03b334b6d381be30a6f77cf6e (patch)
treeb031cacac64e7817d0bb1f8cd9c49cbfd73507d2
parent0eee8188b46d58360173e63421b39725f7d4d5ff (diff)
downloadpyparsing-git-4054216260f8f0c03b334b6d381be30a6f77cf6e.tar.gz
Support Python 3.123.1.0b1
-rw-r--r--CHANGES2
-rw-r--r--pyproject.toml1
-rw-r--r--tox.ini2
3 files changed, 4 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index ddbddac..342e848 100644
--- a/CHANGES
+++ b/CHANGES
@@ -15,6 +15,8 @@ Version 3.2.0 will also discontinue support for Python versions 3.6 and 3.7.
Version 3.1.0b1 - April, 2023
-----------------------------
+- Added support for Python 3.12.
+
- API CHANGE: A slight change has been implemented when unquoting a quoted string
parsed using the QuotedString class. Formerly, when unquoting and processing
whitespace markers such as \t and \n, these substitutions would occur first, and
diff --git a/pyproject.toml b/pyproject.toml
index 7d21f5e..d303a9a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -23,6 +23,7 @@ classifiers = [
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
"Programming Language :: Python :: 3 :: Only",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
diff --git a/tox.ini b/tox.ini
index 6ae0f77..da33cf8 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
skip_missing_interpreters=true
envlist =
- py{36,37,38,39,310,311,py3},mypy-test
+ py{36,37,38,39,310,311,312,py3},mypy-test
isolated_build = True
[testenv]