summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Rosen <sirosen@globus.org>2022-05-30 18:25:13 -0400
committerGitHub <noreply@github.com>2022-05-30 17:25:13 -0500
commit48168419f460287ab410bf3370a6828de9d837bb (patch)
tree267963496a7ee362b1d52de711bec619837fcc0d
parentd570869a9ba683c021545e53bb1ba159bee7c2af (diff)
downloadpyparsing-git-48168419f460287ab410bf3370a6828de9d837bb.tar.gz
Enable mypy-test in CI (#406)
With the updated matrix build config, it's now possible to add a py3.10 build to run `tox -e mypy-test`. Also, fix a bug in the workflow in on.pull_request.paths
-rw-r--r--.github/workflows/ci.yml4
-rw-r--r--tox.ini13
2 files changed, 8 insertions, 9 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index d6bf2bc..5996eb9 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -6,7 +6,7 @@ on:
pull_request:
paths:
- - .github/workflows/cis.yml
+ - .github/workflows/ci.yml
- pyparsing/*
- pyproject.toml
- tox.ini
@@ -23,6 +23,8 @@ jobs:
include:
- python-version: "3.10"
os: macos-latest
+ - python-version: "3.10"
+ toxenv: mypy-test
- python-version: "pypy-3.7"
env:
TOXENV: ${{ matrix.toxenv || 'py' }}
diff --git a/tox.ini b/tox.ini
index 125208c..49e1690 100644
--- a/tox.ini
+++ b/tox.ini
@@ -10,14 +10,11 @@ extras=diagrams
commands=
coverage run --parallel --branch -m unittest
-# commented out mypy-test until CI can support running it
-# see: https://github.com/pyparsing/pyparsing/pull/402
-#
-# [testenv:mypy-test]
-# deps = mypy==0.960
-# # note: cd to tests/ to avoid mypy trying to check pyparsing (which fails)
-# changedir = tests
-# commands = mypy --show-error-codes --warn-unused-ignores mypy-ignore-cases/
+[testenv:mypy-test]
+deps = mypy==0.960
+# note: cd to tests/ to avoid mypy trying to check pyparsing (which fails)
+changedir = tests
+commands = mypy --show-error-codes --warn-unused-ignores mypy-ignore-cases/
[testenv:pyparsing_packaging]
deps=