summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorptmcg <ptmcg@austin.rr.com>2023-03-05 05:00:20 -0600
committerptmcg <ptmcg@austin.rr.com>2023-03-05 05:00:20 -0600
commit5d95272d98b8bce1ac53b10bdef6db12b0230dfa (patch)
treef969b5f8071355beaf9109091e67bdb97cb14b38
parentb20231a92b1282953c26e0d350a760bade394ca1 (diff)
downloadpyparsing-git-5d95272d98b8bce1ac53b10bdef6db12b0230dfa.tar.gz
Python versions - add 3.11 to tox.ini, add 3.6 back to pyproject.toml (last version to support 3.6!)
-rw-r--r--pyproject.toml1
-rw-r--r--tox.ini2
2 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c54a1aa..3714d8b 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,6 +17,7 @@ classifiers = [
"Operating System :: OS Independent",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
diff --git a/tox.ini b/tox.ini
index dc1ae09..6ae0f77 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
skip_missing_interpreters=true
envlist =
- py{36,37,38,39,310,py3},mypy-test
+ py{36,37,38,39,310,311,py3},mypy-test
isolated_build = True
[testenv]