summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavlo Bashynskyi <levonet@gmail.com>2021-12-06 17:47:05 +0200
committerGitHub <noreply@github.com>2021-12-06 09:47:05 -0600
commit7d53dca817045e1eeb9342a38f84a995f64c21b8 (patch)
tree8b7184737ad352ff9d4c0714d56d6c3aaf919b79
parent18ea2e761a7d1a097d9b42064678d1d10aba803c (diff)
downloadpyparsing-git-7d53dca817045e1eeb9342a38f84a995f64c21b8.tar.gz
Switch to GH actions (#341)
* Switch to GH actions * Add dependencies for railroad testing
-rw-r--r--.github/workflows/ci.yml58
-rw-r--r--.travis.yml28
-rw-r--r--README.rst4
3 files changed, 60 insertions, 30 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
new file mode 100644
index 0000000..62ffd79
--- /dev/null
+++ b/.github/workflows/ci.yml
@@ -0,0 +1,58 @@
+name: Continuous Integration
+on:
+ push:
+ branches:
+ - master
+
+ pull_request:
+ paths:
+ - .github/workflows/cis.yml
+ - pyparsing/*
+ - setup.py
+ - tox.ini
+
+jobs:
+ tests:
+ name: Unit tests
+ runs-on: ${{ matrix.os || 'ubuntu-latest' }}
+ strategy:
+ matrix:
+ include:
+ - python-version: "3.6"
+ toxenv: py36
+ - python-version: "3.7"
+ toxenv: py37
+ - python-version: "3.8"
+ toxenv: py38
+ - python-version: "3.9"
+ toxenv: py39
+ - python-version: "3.10"
+ toxenv: py310
+ - python-version: "3.10"
+ toxenv: py310
+ os: macos-latest
+ - python-version: "pypy-3.7"
+ toxenv: pypy3
+ env:
+ TOXENV: ${{ matrix.toxenv }}
+ steps:
+ - uses: actions/checkout@v2
+
+ - name: Set up Python ${{ matrix.python-version }}
+ uses: actions/setup-python@v2
+ with:
+ python-version: ${{ matrix.python-version }}
+
+ - name: Install dependencies
+ run: |
+ python -m pip install --upgrade pip
+ python -m pip install tox codecov railroad-diagrams Jinja2
+
+ - name: Test
+ run: tox -e ALL
+
+ - name: Upload coverage to Codecov
+ if: ${{ matrix.os == 'ubuntu-latest' && matrix.python-version == '3.10' }}
+ env:
+ CODECOV_TOKEN: ${{ secrets.CODECOV_TOKEN }}
+ run: codecov
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index e059770..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,28 +0,0 @@
-language: python
-
-dist: xenial
-
-matrix:
- include:
- - python: "3.6"
- env: TOXENV=py36
- - python: "3.7"
- env: TOXENV=py37
- - python: "3.8"
- env: TOXENV=py38
- - python: "3.9"
- env: TOXENV=py39
- - python: "3.10-dev"
- env: TOXENV=py310
- - python: "pypy3"
- env: TOXENV=pypy3
- fast_finish: true
-
-install:
- - pip install tox codecov
-
-script:
- - tox -e ALL
-
-after_success:
- - codecov
diff --git a/README.rst b/README.rst
index 62e9741..f51c9dd 100644
--- a/README.rst
+++ b/README.rst
@@ -70,7 +70,7 @@ History
See `CHANGES <https://github.com/pyparsing/pyparsing/blob/master/CHANGES>`__ file.
-.. |Build Status| image:: https://travis-ci.com/pyparsing/pyparsing.svg?branch=master
- :target: https://travis-ci.com/pyparsing/pyparsing
+.. |Build Status| image:: https://github.com/pyparsing/pyparsing/actions/workflows/ci.yml/badge.svg
+ :target: https://github.com/pyparsing/pyparsing/actions/workflows/ci.yml
.. |Coverage| image:: https://codecov.io/gh/pyparsing/pyparsing/branch/master/graph/badge.svg
:target: https://codecov.io/gh/pyparsing/pyparsing