summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Kanakarakis <ivan.kanak@gmail.com>2023-02-14 16:03:01 +0200
committerIvan Kanakarakis <ivan.kanak@gmail.com>2023-02-14 16:03:01 +0200
commit13ddd1fad436df4c23cf93b340c07a9aeaf2ad47 (patch)
tree9bd4a82a00623af1cf8bb63e4fa1c0c55912553e
parent9b565f93640a7fffd4f48e7f121d2f6663952293 (diff)
downloadpysaml2-13ddd1fad436df4c23cf93b340c07a9aeaf2ad47.tar.gz
Update publish instructions
Signed-off-by: Ivan Kanakarakis <ivan.kanak@gmail.com>
-rw-r--r--RELEASE.md28
1 files changed, 6 insertions, 22 deletions
diff --git a/RELEASE.md b/RELEASE.md
index fc29a18a..e57d1144 100644
--- a/RELEASE.md
+++ b/RELEASE.md
@@ -41,31 +41,15 @@ When releasing a new version, the following steps should be taken:
7. Push the changes and the release to Github:
- ```
- git push --follow-tags
- ```
+ ```
+ git push --follow-tags
+ ```
8. Publish the release on PyPI:
- generate a source and wheel distribution at once
- ```
- python setup.py sdist bdist_wheel
- ```
-
- generated files are under dist/
- ```
- ls dist/
- ```
-
- upload release on test.pypi.org
- ```
- twine upload --repository-url https://test.pypi.org/legacy/ dist/pysaml2-X.Y.Z*
- ```
-
- then, upload release on official pypi.org
- ```
- twine upload dist/pysaml2-X.Y.Z*
- ```
+ ```
+ poetry publish --build
+ ```
9. Send an email to the pysaml2 list announcing this release