summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--pyproject.toml26
-rw-r--r--tox.ini22
2 files changed, 26 insertions, 22 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0a1785ff..c22a3d44 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -245,3 +245,29 @@ warn_unused_configs = true
warn_unreachable = true
install_types = true
non_interactive = true
+
+[tool.tox]
+legacy_tox_ini = """
+[tox]
+isolated_build = true
+envlist =
+ py36
+ py37
+ py38
+ py39
+ py310
+
+[testenv]
+skip_install = true
+whitelist_externals =
+ xmlsec1
+ poetry
+commands_pre =
+ poetry install --with test,coverage
+ xmlsec1 --version
+ poetry run python --version
+ poetry run pytest --version
+ poetry run tox --version
+commands =
+ poetry run pytest --import-mode=importlib --cov=saml2 --cov-report=term-missing
+"""
diff --git a/tox.ini b/tox.ini
deleted file mode 100644
index ad3a44a7..00000000
--- a/tox.ini
+++ /dev/null
@@ -1,22 +0,0 @@
-[tox]
-isolated_build = true
-envlist =
- py36
- py37
- py38
- py39
- py310
-
-[testenv]
-skip_install = true
-whitelist_externals =
- xmlsec1
- poetry
-commands_pre =
- poetry install --with test,coverage
- xmlsec1 --version
- poetry run python --version
- poetry run pytest --version
- poetry run tox --version
-commands =
- poetry run pytest --import-mode=importlib --cov=saml2 --cov-report=term-missing