summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGerman M. Bravo <german.mb@deipi.com>2011-02-26 15:20:27 -0600
committerGerman M. Bravo <german.mb@deipi.com>2011-02-26 15:20:27 -0600
commit5cee1d85a5edc22867d4f639a063994249477348 (patch)
treeb06feec851a3186202e9d8b35ab05d8dccfa67b7 /setup.py
parent5e27c80276b638145b79564c4b9b232edbe855f2 (diff)
downloadpyscss-5cee1d85a5edc22867d4f639a063994249477348.tar.gz
Scss version bump to v1.0rc1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..c3dc61c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,35 @@
+#!/usr/bin/env python
+from setuptools import setup
+
+from scss import PROJECT, URL, VERSION, AUTHOR, AUTHOR_EMAIL, LICENSE, DOWNLOAD_URL
+
+def read(fname):
+ import os
+ try:
+ return open(os.path.join(os.path.dirname( __file__ ), fname)).read().strip()
+ except IOError:
+ return ''
+
+setup(name=PROJECT,
+ version=VERSION,
+ description=read('DESCRIPTION'),
+ long_description=read('README.rst'),
+ author=AUTHOR,
+ author_email=AUTHOR_EMAIL,
+ url=URL,
+ download_url=DOWNLOAD_URL,
+ py_modules=[
+ 'scss',
+ ],
+ license=LICENSE,
+ keywords='css oocss xcss sass scss precompiler',
+ classifiers=["Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Code Generators",
+ "Topic :: Text Processing :: Markup",
+ "Topic :: Software Development :: Libraries :: Python Modules"
+ ],
+ )