summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEevee (Alex Munroe) <eevee.git@veekun.com>2014-10-13 15:33:43 -0700
committerEevee (Alex Munroe) <eevee.git@veekun.com>2014-10-13 15:33:43 -0700
commit60556d09148c3c232734b88637eb9e7e3edf071d (patch)
treedf3f831590871ad6a534f52bf529914c0222543d /setup.py
parent71e8a891eb22b702bd8000f27993cfdb3f1c40c4 (diff)
downloadpyscss-60556d09148c3c232734b88637eb9e7e3edf071d.tar.gz
Trying that again...
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 6129032..3615565 100644
--- a/setup.py
+++ b/setup.py
@@ -10,8 +10,8 @@ from setuptools import setup, Extension, Feature
# this imports PROJECT, URL, VERSION, AUTHOR, AUTHOR_EMAIL, LICENSE,
# DOWNLOAD_URL
-with open('scss/scss_meta.py') as f:
- exec(f.read().decode('utf8'))
+with open('scss/scss_meta.py', 'rb') as f:
+ exec(f.read())
# Dependencies
install_requires = ['six']
@@ -76,7 +76,7 @@ def echo(msg=''):
def read(fname):
try:
- with open(os.path.join(os.path.dirname(__file__), fname)) as f:
+ with open(os.path.join(os.path.dirname(__file__), fname), 'rb') as f:
return f.read().decode('utf8').strip()
except IOError:
return ''