summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Khyn <thomas@ksytek.com>2014-08-25 14:48:46 +1200
committerThomas Khyn <thomas@ksytek.com>2014-08-25 14:48:46 +1200
commit683630495cd7a3e5680c6adb70dfcc53dea24e77 (patch)
tree65f8a588f4b4b25502c6f8799ee0997bdcedb7a4 /setup.py
parented05592510f8c826348438ec64a7a12eaf1c3121 (diff)
downloadpyscss-683630495cd7a3e5680c6adb70dfcc53dea24e77.tar.gz
Six install in the package dir is not necessary anymore
Scss module does not need to be imported to load the variables from scss.scss_meta
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 3 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 78f3a49..a3993f1 100644
--- a/setup.py
+++ b/setup.py
@@ -7,12 +7,10 @@ import platform
import sys
from setuptools import setup, Extension, Feature
-from setuptools.dist import Distribution
-# Need to install `six` to be able to import from the scss namespace
-Distribution(dict(setup_requires='six'))
-
-from scss.scss_meta import PROJECT, URL, VERSION, AUTHOR, AUTHOR_EMAIL, LICENSE, DOWNLOAD_URL
+# this imports PROJECT, URL, VERSION, AUTHOR, AUTHOR_EMAIL, LICENSE,
+# DOWNLOAD_URL, INSTALL_REQUIRES
+exec(open('scss/scss_meta.py').read())
# fail safe compilation shamelessly stolen from the simplejson
# setup.py file. Original author: Bob Ippolito