summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEevee (Alex Munroe) <eevee.git@veekun.com>2013-10-08 14:52:42 -0700
committerEevee (Alex Munroe) <eevee.git@veekun.com>2013-10-08 15:27:26 -0700
commit812bac2224b97506fd1563aaff924fceae7cc6ed (patch)
tree5baf8cf56ac03b00e238f335fb7262e4ad218722 /setup.py
parent58c84e9fad1546007e2aae04bc3a27651558b6b6 (diff)
downloadpyscss-812bac2224b97506fd1563aaff924fceae7cc6ed.tar.gz
Fix setup.py, probably.
- tests.rst is gone. - We work on 2 and 3 with the same codebase; no need for 2to3. - Don't recursively include EVERYTHING in the manifest. Conflicts: scss/scss_meta.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 0 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index a2ee273..a8001df 100644
--- a/setup.py
+++ b/setup.py
@@ -37,11 +37,6 @@ if sys.platform == 'win32' and sys.version_info > (2, 6):
ext_errors += (IOError,)
-extra = {}
-if sys.version_info >= (3, 0):
- extra['use_2to3'] = True
-
-
class BuildFailed(Exception):
pass
@@ -112,14 +107,12 @@ def run_setup(with_binary):
'scss.functions',
'scss.functions.compass',
],
- package_data={'scss': ['tests.rst']},
cmdclass={'build_ext': ve_build_ext},
features=features,
entry_points="""
[console_scripts]
pyscss = scss.tool:main
""",
- **extra
)