summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEevee (Alex Munroe) <eevee.git@veekun.com>2013-09-16 12:47:58 -0700
committerEevee (Alex Munroe) <eevee.git@veekun.com>2013-09-16 12:48:11 -0700
commitfcaaf7f7c977e553c9cf771c70ef262b23bbc419 (patch)
tree6566286ebb9c8e7fece3622d96aca5b8ecdeaa08 /setup.py
parent1e28b7fd40e0daf2a3d1d8cd0e379b24358752be (diff)
downloadpyscss-fcaaf7f7c977e553c9cf771c70ef262b23bbc419.tar.gz
Fix setup.py requiring `six` just to import. #204
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 85de7db..1c22133 100644
--- a/setup.py
+++ b/setup.py
@@ -2,10 +2,14 @@
import os
import sys
from setuptools import setup, Extension, Feature
+from setuptools.dist import Distribution
from distutils.command.build_ext import build_ext
from distutils.errors import CCompilerError, DistutilsExecError, \
DistutilsPlatformError
+# Need to install `six` to be able to import from the scss namespace
+Distribution(dict(setup_requires='six'))
+
from scss.scss_meta import PROJECT, URL, VERSION, AUTHOR, AUTHOR_EMAIL, LICENSE, DOWNLOAD_URL
# fail safe compilation shamelessly stolen from the simplejson