summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2021-07-30 17:01:54 +0200
committerGitHub <noreply@github.com>2021-07-30 17:01:54 +0200
commit2ffdd452b03dd4b639cda985bd67b8d4c0c34a5f (patch)
tree4d713944f6140af809888c2cb2749af62082ed01
parent38a173ba9b827d82b19abc2ff83ead36183ffc9a (diff)
parent68fc6af213fec578549602da8cb40cee1302a5f8 (diff)
downloadpysendfile-master.tar.gz
Merge pull request #38 from D3X/python3.9HEADmaster
Run tests on Python 3.9
-rw-r--r--.travis.yml6
-rw-r--r--setup.py7
-rw-r--r--tox.ini27
3 files changed, 8 insertions, 32 deletions
diff --git a/.travis.yml b/.travis.yml
index fa154dc..623ff2f 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,10 +5,10 @@ matrix:
include:
# Linux
- python: 2.7
- - python: 3.4
- - python: 3.5
- python: 3.6
- python: 3.7
+ - python: 3.8
+ - python: 3.9
dist: xenial
sudo: true
- python: pypy
@@ -19,7 +19,7 @@ matrix:
env: PYVER=py27
- language: generic
os: osx
- env: PYVER=py36
+ env: PYVER=py39
install:
- ./.ci/travis/install.sh
script:
diff --git a/setup.py b/setup.py
index 55962c1..54a991a 100644
--- a/setup.py
+++ b/setup.py
@@ -24,10 +24,11 @@
# ======================================================================
import sys
+
try:
- from setuptools import setup, Extension
+ from setuptools import Extension, setup
except ImportError:
- from distutils.core import setup, Extension
+ from distutils.core import Extension, setup
NAME = 'pysendfile'
@@ -75,6 +76,8 @@ def main():
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Topic :: System :: Networking',
'Topic :: System :: Operating System',
'Topic :: Internet :: File Transfer Protocol (FTP)',
diff --git a/tox.ini b/tox.ini
deleted file mode 100644
index 72dc6e2..0000000
--- a/tox.ini
+++ /dev/null
@@ -1,27 +0,0 @@
-# Tox (http://tox.testrun.org/) is a tool for running tests
-# in multiple virtualenvs. This configuration file will run the
-# test suite on all supported python versions.
-# To use it run "pip install tox" and then run "tox" from this
-# directory.
-
-[tox]
-envlist = py26, py27, py32, py33, py34
-
-[testenv]
-deps =
- pytest
- flake8
-setenv =
- PYTHONPATH = {toxinidir}/test
-commands =
- python test/test_sendfile.py
- flake8 --exclude=build,.tox,.git
-
-[testenv:py26]
-deps =
- flake8
- pytest
- unittest2
-commands =
- python test/test_sendfile.py
- flake8 --exclude=build,.tox,.git