summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2012-01-12 19:09:48 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2012-01-12 19:09:48 +0000
commit0fa69a673287cca1a4a759ee9f8171e1799a4489 (patch)
tree7c8fcd7823a3cdb1696601d9389a8656a6483397
parentbfa2f2482f543a873765e69ed99fa71067f6aa2a (diff)
downloadpysendfile-0fa69a673287cca1a4a759ee9f8171e1799a4489.tar.gz
add license in all source files
-rw-r--r--HISTORY28
-rw-r--r--setup.py23
-rw-r--r--test/benchmark.py31
-rw-r--r--test/test_sendfile.py23
4 files changed, 97 insertions, 8 deletions
diff --git a/HISTORY b/HISTORY
index b9ed22f..30ef941 100644
--- a/HISTORY
+++ b/HISTORY
@@ -5,17 +5,37 @@ Version 2.0.0 - XXXX-XX-XX
(Giampaolo RodolĂ  took over maintenance)
-#1: test suite
+##: complete rewriting except AIX code
+##: non blocking sockets support
+##: threads support (release GIL)
+#1: unit tests
#2: python 3 support
#3: FreeBSD implementation is broken
#4: python large file support
#5: header/trailer are now keyword arguments
#6: exposed SF_NODISKIO, SF_MNOWAIT and SF_SYNC constants on FreeBSD
#8: benchmark script
-#10: OSX support
+#10: Mac OSX support
+#13: Sun OS support
+
Version 1.2.4 - 2009-03-06
==========================
-Last release, maintained by Stephan Peijnik.
-Support for AIX, FreeBSD, Dragonfly BSD, OSX Linux.
+(Stephan Peijnik took over maintenance)
+
+## Add AIX support.
+
+
+Version 1.2.3 - 2008-04-09
+==========================
+
+## Use setuptools instead of distutils.
+
+
+Version 1.2.2 - 2008-03-29
+==========================
+
+(Ben Woolley)
+
+## First release including support for Linux, FreeBSD and Dragonfly platforms.
diff --git a/setup.py b/setup.py
index 66406ce..2ff011d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,29 @@
#!/usr/bin/env python
# $Id$
+# ======================================================================
+# This software is distributed under the MIT license reproduced below:
+#
+# Copyright (C) 2009-2012 Giampaolo Rodola' <g.rodola@gmail.com>
+#
+# Permission to use, copy, modify, and distribute this software and
+# its documentation for any purpose and without fee is hereby
+# granted, provided that the above copyright notice appear in all
+# copies and that both that copyright notice and this permission
+# notice appear in supporting documentation, and that the name of
+# Giampaolo Rodola' not be used in advertising or publicity pertaining to
+# distribution of the software without specific, written prior
+# permission.
+#
+# Giampaolo Rodola' DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT Giampaolo Rodola' BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+# ======================================================================
+
import sys
try:
from setuptools import setup, Extension
diff --git a/test/benchmark.py b/test/benchmark.py
index 56d86d5..858bb8f 100644
--- a/test/benchmark.py
+++ b/test/benchmark.py
@@ -1,6 +1,29 @@
#!/usr/bin/env python
# $Id$
+# ======================================================================
+# This software is distributed under the MIT license reproduced below:
+#
+# Copyright (C) 2009-2012 Giampaolo Rodola' <g.rodola@gmail.com>
+#
+# Permission to use, copy, modify, and distribute this software and
+# its documentation for any purpose and without fee is hereby
+# granted, provided that the above copyright notice appear in all
+# copies and that both that copyright notice and this permission
+# notice appear in supporting documentation, and that the name of
+# Giampaolo Rodola' not be used in advertising or publicity pertaining to
+# distribution of the software without specific, written prior
+# permission.
+#
+# Giampaolo Rodola' DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT Giampaolo Rodola' BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+# ======================================================================
+
"""
A simle benchmark script which compares plain send() and sendfile()
performances in terms of CPU time spent and bytes transmitted in
@@ -93,7 +116,7 @@ class Spinner(threading.Thread):
def stop(self):
self._exit = True
self.join()
-
+
class Client:
@@ -135,11 +158,11 @@ def start_server(use_sendfile, keep_sending=False):
file = open(BIGFILE, 'rb')
def on_exit(signum, fram):
- file.close();
+ file.close();
conn.close()
sys.exit(0)
- signal.signal(signal.SIGTERM, on_exit)
- signal.signal(signal.SIGINT, on_exit)
+ signal.signal(signal.SIGTERM, on_exit)
+ signal.signal(signal.SIGINT, on_exit)
if not use_sendfile:
while 1:
diff --git a/test/test_sendfile.py b/test/test_sendfile.py
index ccb1b2c..01ab5fc 100644
--- a/test/test_sendfile.py
+++ b/test/test_sendfile.py
@@ -3,6 +3,29 @@
# $Id$
#
+# ======================================================================
+# This software is distributed under the MIT license reproduced below:
+#
+# Copyright (C) 2009-2012 Giampaolo Rodola' <g.rodola@gmail.com>
+#
+# Permission to use, copy, modify, and distribute this software and
+# its documentation for any purpose and without fee is hereby
+# granted, provided that the above copyright notice appear in all
+# copies and that both that copyright notice and this permission
+# notice appear in supporting documentation, and that the name of
+# Giampaolo Rodola' not be used in advertising or publicity pertaining to
+# distribution of the software without specific, written prior
+# permission.
+#
+# Giampaolo Rodola' DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT Giampaolo Rodola' BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+# ======================================================================
+
"""
pysendfile test suite; works with both python 2.x and 3.x (no need
to run 2to3 tool first).