summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2012-01-10 23:11:40 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2012-01-10 23:11:40 +0000
commit8f4af20170faf525487c69d233ef7cf065da695a (patch)
tree8468df863b9b69db2ad02ba99c9c78422ab0d568
parentb4ce95058eab43447cbccd75e6404609bac23cdf (diff)
downloadpysendfile-8f4af20170faf525487c69d233ef7cf065da695a.tar.gz
rename project py-sendfile -> pysendfile
-rw-r--r--README6
-rw-r--r--sendfilemodule.c2
-rw-r--r--setup.py27
3 files changed, 20 insertions, 15 deletions
diff --git a/README b/README
index 5872d01..1047e7c 100644
--- a/README
+++ b/README
@@ -3,7 +3,7 @@ About
=====
A python interface to sendfile(2) system call:
-http://code.google.com/p/py-sendfile/
+http://code.google.com/p/pysendfile/
=======
Install
@@ -13,7 +13,7 @@ $ sudo setup.py install
...or:
-$ easy_install py-sendfile
+$ easy_install pysendfile
===================
Supported platforms
@@ -57,7 +57,7 @@ while 1:
Authors
=======
-py-sendfile was originally written by Ben Woolley including Linux and FreeBSD
+pysendfile was originally written by Ben Woolley including Linux and FreeBSD
support.
Later on Niklas Edmundsson took over maintenance and added AIX support.
diff --git a/sendfilemodule.c b/sendfilemodule.c
index 806b448..7453565 100644
--- a/sendfilemodule.c
+++ b/sendfilemodule.c
@@ -3,7 +3,7 @@
*/
/*
- * py-sendfile
+ * pysendfile
*
* A Python module interface to sendfile(2)
*
diff --git a/setup.py b/setup.py
index b53122c..b69a511 100644
--- a/setup.py
+++ b/setup.py
@@ -15,22 +15,29 @@ if 'sunos' in sys.platform:
else:
libraries = []
+name = 'pysendfile'
+version = '0.2.0'
+download_url = "http://pysendfile.googlecode.com/files/" + name + "-" + \
+ version + ".tar.gz"
+
def main():
- setup(name='py-sendfile',
- version='2.0.0',
+ setup(name=name,
+ url='http://code.google.com/p/pysendfile/',
+ version=version,
description='A Python interface to sendfile(2)',
- url='http://code.google.com/p/py-sendfile/',
+ long_description=open('README', 'r').read(),
+ url='http://code.google.com/p/pysendfile/',
author='Giampaolo Rodola',
author_email='g.rodola@gmail.com',
+ download_url=download_url,
license='License :: OSI Approved :: MIT License',
- long_description=open('README', 'r').read(),
keywords=['sendfile', 'ftp'],
- zip_safe=True,
classifiers = [
- 'Development Status :: 4 - Beta',
+ 'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Operating System :: POSIX :: Linux',
'Operating System :: MacOS :: MacOS X',
+ 'Operating System :: POSIX :: BSD',
'Operating System :: POSIX :: BSD :: FreeBSD',
'Operating System :: POSIX :: SunOS/Solaris',
'Operating System :: POSIX :: AIX',
@@ -48,13 +55,11 @@ def main():
'Topic :: System :: Operating System',
'Topic :: Internet :: File Transfer Protocol (FTP)',
'Topic :: Internet :: WWW/HTTP',
- 'License :: OSI Approved :: GNU Library or Lesser General ' \
- 'Public License (LGPL)',
- ],
+ 'License :: OSI Approved :: GNU Library or Lesser General ',
+ ],
ext_modules = [Extension('sendfile',
sources=['sendfilemodule.c'],
libraries=libraries)],
)
-if __name__ == '__main__':
- main()
+main()