summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2011-02-03 12:35:35 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2011-02-03 12:35:35 +0000
commitbfae5cab1e93098f2b1f44b53ed1971bdeeb72a4 (patch)
tree63e01d4c7f442aabb8cfcca49598c4212f768707
parentabffb9342437f3882dd52ea69699ac4fc293845f (diff)
downloadpysendfile-bfae5cab1e93098f2b1f44b53ed1971bdeeb72a4.tar.gz
re-define classifiers in setup.py, update maintainer, add HISTORY file
-rw-r--r--HISTORY12
-rw-r--r--setup.cfg5
-rw-r--r--setup.py15
3 files changed, 18 insertions, 14 deletions
diff --git a/HISTORY b/HISTORY
new file mode 100644
index 0000000..0dfb681
--- /dev/null
+++ b/HISTORY
@@ -0,0 +1,12 @@
+Bug tracker at http://code.google.com/p/py-sendfile/issues/list
+
+Version 2.0.0 - XXXX-XX-XX
+==========================
+
+-- Giampaolo RodolĂ  took over maintenance --
+
+
+Version 1.2.4 - 2009-03-06
+==========================
+
+Last release, maintained by Stephan Peijnik
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 861a9f5..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,5 +0,0 @@
-[egg_info]
-tag_build =
-tag_date = 0
-tag_svn_revision = 0
-
diff --git a/setup.py b/setup.py
index ce729b1..773336b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,4 @@
-from setuptools import setup
-from distutils.core import Extension
+from distutils.core import setup, Extension
sendfile_module = Extension('sendfile',
sources = ['sendfilemodule.c'])
@@ -7,22 +6,20 @@ sendfile_module = Extension('sendfile',
setup (name = 'py-sendfile',
version = '1.2.4',
description = 'A Python interface to sendfile(2)',
- author = 'Ben Woolley',
+ author = 'Ben Woolley',
author_email = 'user tautolog at gmail',
- maintainer = 'Stephan Peijnik',
- maintainer_email = 'stephan@peijnik.at',
- url = 'http://code.sp-its.at/projects/py-sendfile',
+ maintainer = "Giampaolo Rodola'",
+ maintainer_email = 'g.rodola@gmail.com',
+ url = 'http://code.google.com/p/py-sendfile/',
license = 'LGPLv2.1+',
classifiers = [
- 'Development Status :: 5 - Production/Stable',
+ 'Development Status :: 4 - Beta',
'Intended Audience :: Developers',
'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)',
'Operating System :: POSIX :: Linux',
'Operating System :: POSIX :: BSD :: FreeBSD',
'Operating System :: POSIX :: AIX',
'Programming Language :: C',
-
],
ext_modules = [sendfile_module],
- zip_safe = False,
)