summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2012-01-12 20:38:31 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2012-01-12 20:38:31 +0000
commitfb3a964109eb3a90eea1ed8b84c0ee870b59e0bd (patch)
treecf870a852dcd46b446978ba2088b39a6bf2a2070 /setup.py
parent7f007410b0029044ff67082cc8d8bcefa0412050 (diff)
downloadpysendfile-fb3a964109eb3a90eea1ed8b84c0ee870b59e0bd.tar.gz
use RestructuredText for README so that pypi page looks nice
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 2ff011d..b29c3fc 100644
--- a/setup.py
+++ b/setup.py
@@ -52,7 +52,8 @@ def main():
author='Giampaolo Rodola',
author_email='g.rodola@gmail.com',
download_url=download_url,
- license='License :: OSI Approved :: MIT License',
+ platforms='UNIX',
+ license='MIT',
keywords=['sendfile', 'python', 'performance', 'ftp'],
classifiers = [
'Development Status :: 5 - Production/Stable',
@@ -72,12 +73,11 @@ def main():
'Programming Language :: Python :: 3.0',
'Programming Language :: Python :: 3.1',
'Programming Language :: Python :: 3.2',
- 'Programming Language :: Python :: 3.3',
'Topic :: System :: Networking',
'Topic :: System :: Operating System',
'Topic :: Internet :: File Transfer Protocol (FTP)',
'Topic :: Internet :: WWW/HTTP',
- 'License :: OSI Approved :: GNU Library or Lesser General ',
+ 'License :: OSI Approved :: MIT License',
],
ext_modules = [Extension('sendfile',
sources=['sendfilemodule.c'],