summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2010-07-21 14:04:54 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2010-07-21 14:04:54 +0000
commit5c72e4d3c2e947383f0bbf375ba91f733c32271b (patch)
tree6527b95e8a9698ab115a45c0214144853d973fa0
parent74308e462f4981836af5c276982d84d9ecc207f5 (diff)
downloadpyserial-git-5c72e4d3c2e947383f0bbf375ba91f733c32271b.tar.gz
- python3, pip
- use False instead of 0
-rw-r--r--pyserial/documentation/pyserial.rst19
-rw-r--r--pyserial/documentation/pyserial_api.rst5
2 files changed, 18 insertions, 6 deletions
diff --git a/pyserial/documentation/pyserial.rst b/pyserial/documentation/pyserial.rst
index 0bc6522..017e6bc 100644
--- a/pyserial/documentation/pyserial.rst
+++ b/pyserial/documentation/pyserial.rst
@@ -12,7 +12,7 @@ automatically selects the appropriate backend.
It is released under a free software license, see LICENSE_ for more
details.
-Copyright (C) 2001-2009 Chris Liechti <cliechti(at)gmx.net>
+Copyright (C) 2001-2010 Chris Liechti <cliechti(at)gmx.net>
Other pages (online)
@@ -62,16 +62,24 @@ is required..
From source (tar.gz or checkout)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-http://pypi.python.org/pypi/pyserial
+Download the archive from http://pypi.python.org/pypi/pyserial.
Unpack the archive, enter the ``pyserial-x.y`` directory and run::
python setup.py install
-Setuptools/PyPI
-~~~~~~~~~~~~~~~
+For Python 3.x::
+
+ python3 setup.py install
+
+From PyPI
+~~~~~~~~~
Alternatively it can be installed from PyPI, either manually downloading the
files and installing as described above or using::
+ pip pyserial
+
+or::
+
easy_install -U pyserial
Packages
@@ -79,7 +87,8 @@ Packages
There are also packaged versions for some Linux distributions and Windows:
Debian/Ubuntu
- A package is available under the name "python-serial".
+ A package is available under the name "python-serial". Note that some
+ distributions package an older version of pySerial.
Windows
There is also a Windows installer for end users. It is located in the
diff --git a/pyserial/documentation/pyserial_api.rst b/pyserial/documentation/pyserial_api.rst
index 14f1848..f5b0926 100644
--- a/pyserial/documentation/pyserial_api.rst
+++ b/pyserial/documentation/pyserial_api.rst
@@ -12,7 +12,7 @@ Native ports
.. class:: Serial
- .. method:: __init__(port=None, baudrate=9600, bytesize=EIGHTBITS, parity=PARITY_NONE, stopbits=STOPBITS_ONE, timeout=None, xonxoff=0, rtscts=0, writeTimeout=None, dsrdtr=False, interCharTimeout=None)
+ .. method:: __init__(port=None, baudrate=9600, bytesize=EIGHTBITS, parity=PARITY_NONE, stopbits=STOPBITS_ONE, timeout=None, xonxoff=False, rtscts=False, writeTimeout=None, dsrdtr=False, interCharTimeout=None)
:param port:
Device name or port number number or :const:`None`.
@@ -86,6 +86,9 @@ Native ports
*dsrdtr* is not supported by all platforms (silently ignored). Setting
it to ``None`` has the effect that its state follows *rtscts*.
+ .. versionchanged:: 2.5
+ *dsrdtr* now defaults fo False (instead of *None*)
+
.. method:: open()
Open port.