summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-28 01:28:16 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-28 01:28:16 +0000
commitdaf47bad845f742067fe8558aecbaf6d74534e84 (patch)
tree3533562fec1730909995550f9a5afbbb293c2533
parentddd781321d76b0144e3b3a4e31222724bdbaf34d (diff)
downloadpyserial-git-daf47bad845f742067fe8558aecbaf6d74534e84.tar.gz
- doc updates
- rename test_rawio -> test_iolib
-rw-r--r--documentation/examples.rst7
-rw-r--r--documentation/pyserial.rst16
-rw-r--r--documentation/pyserial_api.rst3
-rw-r--r--pyserial/examples/test_iolib.py (renamed from pyserial/examples/test_rawio.py)2
-rw-r--r--pyserial/setup.py2
5 files changed, 17 insertions, 13 deletions
diff --git a/documentation/examples.rst b/documentation/examples.rst
index e0181bb..283f2d6 100644
--- a/documentation/examples.rst
+++ b/documentation/examples.rst
@@ -206,6 +206,8 @@ wxTerminal.py_
limited by wx and it may suddenly stop displaying new input.
wxTerminal.wxg_
+test_high_load.py_
+ Tests involving sending a lot of data.
A wxGlade design file for the terminal application.
wxSerialConfigDialog.py_
@@ -270,6 +272,11 @@ test_advanced.py_
test_high_load.py_
Tests involving sending a lot of data.
+test_iolib.py_
+ Tests involving the :mod:`io` library. Only available for Python 2.6 and
+ newer.
+
.. _test.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/test.py
.. _test_advanced.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/test_advanced.py
.. _test_high_load.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/test_high_load.py
+.. _test_iolib.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/test_iolib.py
diff --git a/documentation/pyserial.rst b/documentation/pyserial.rst
index 2153f91..2db8c21 100644
--- a/documentation/pyserial.rst
+++ b/documentation/pyserial.rst
@@ -28,12 +28,8 @@ The homepage is at http://pyserial.sf.net.
Features
========
* Same class based interface on all supported platforms.
-* Access to the port settings through Python 2.3+ properties.
-* Port numbering starts at zero, no need to know the port name in the user
- program.
-* Port string (device name) can be specified if access through numbering is
- inappropriate.
-* Support for different bytesizes, stopbits, parity and flow control with
+* Access to the port settings through Python properties.
+* Support for different byte sizes, stop bits, parity and flow control with
RTS/CTS and/or Xon/Xoff.
* Working with or without receive timeout.
* File like API with "read" and "write" ("readline" etc. also supported).
@@ -41,11 +37,12 @@ Features
* The port is set up for binary transmission. No NULL byte stripping, CR-LF
translation etc. (which are many times enabled for POSIX.) This makes this
module universally useful.
+* Compatible with :mod:`io` library (Python 2.6+)
Requirements
============
-* Python 2.3 or newer
+* Python 2.3 or newer, including Python 3.x
* ctypes extensions on Windows (is in standard library since Python 2.5+)
* "Java Communications" (JavaComm) or compatible extension for Java/Jython
@@ -57,8 +54,6 @@ pyserial
--------
This installs a package that can be used from Python (``import serial``).
-The Python pywin32 library needs to be installed on Windows.
-
To install the module for all users on the system, administrator rights (root)
is required..
@@ -108,7 +103,8 @@ Older versions are still available on the `Download Page`_. pySerial 1.21 is
compatible with Python 2.0 on Windows, Linux and several un*x like systems,
MacOSX and Jython.
-On windows they will depend on pywin32_ (previously known as win32all)
+On windows releases older than 2.5 will depend on pywin32_ (previously known as
+win32all)
.. _`Download Page`: http://sourceforge.net/project/showfiles.php?group_id=46487
.. _pywin32: http://pypi.python.org/pypi/pywin32
diff --git a/documentation/pyserial_api.rst b/documentation/pyserial_api.rst
index 08f1b45..9833254 100644
--- a/documentation/pyserial_api.rst
+++ b/documentation/pyserial_api.rst
@@ -503,7 +503,8 @@ Byte size
Others
-------
-Default control characters for software flow control:
+Default control characters (instnces of :class:`bytes` for Python 3.0+) for
+software flow control:
.. data:: XON
.. data:: XOFF
diff --git a/pyserial/examples/test_rawio.py b/pyserial/examples/test_iolib.py
index 441b37f..2f6cd4b 100644
--- a/pyserial/examples/test_rawio.py
+++ b/pyserial/examples/test_iolib.py
@@ -52,7 +52,7 @@ class Test_SerialAndIO(unittest.TestCase):
def test_hello_raw(self):
self.io.write(unicode("hello\n"))
- self.io.flush()
+ self.io.flush() # it is buffering. required to get the data out
hello = self.io.readline()
self.failUnlessEqual(hello, unicode("hello\n"))
diff --git a/pyserial/setup.py b/pyserial/setup.py
index 4198f32..71fb0f7 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -17,7 +17,7 @@ except ImportError:
if sys.version < '2.3':
# distutils that old can't cope with the "classifiers" or "download_url"
# keywords and True/False constants and basestring are missing
- raise ValueError("Sorry Python versions older than 2.2.3 are no longer"
+ raise ValueError("Sorry Python versions older than 2.3 are no longer"
"supported - check http://pyserial.sf.net for older "
"releases or upgrade your Python installation.")