summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2010-01-02 03:06:21 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2010-01-02 03:06:21 +0000
commitf571644c6136568a9db4722188e33c114ab01003 (patch)
tree15cce5eaeb15047d77da293f17cad3f30f9670bd
parenta9a093ede6decd8ed6a34be3b5f7690a2b50c67b (diff)
downloadpyserial-git-f571644c6136568a9db4722188e33c114ab01003.tar.gz
- update list of changes
- prepare for 2.5-rc2
-rw-r--r--pyserial/CHANGES.txt48
-rw-r--r--pyserial/README.txt2
-rw-r--r--pyserial/serial/__init__.py4
-rw-r--r--pyserial/setup.py2
4 files changed, 44 insertions, 12 deletions
diff --git a/pyserial/CHANGES.txt b/pyserial/CHANGES.txt
index 480b35f..01193c9 100644
--- a/pyserial/CHANGES.txt
+++ b/pyserial/CHANGES.txt
@@ -298,7 +298,7 @@ Bugfixes (jython):
- The Jython backend tries javax.comm and gnu.io (Seo Sanghyeon)
-Version 2.5 <date>
+Version 2.5-rc1 2009-07-30
---------------------------
New Features:
@@ -307,19 +307,14 @@ New Features:
- Support for Win32 is now written on the top of ctypes (bundled with
Python 2.5+) instead of pywin32 (patch by Giovanni Bajo).
- 1.5 stop bits (STOPBITS_ONE_POINT_FIVE, implemented on all platforms)
-- Documentation update, now written with Sphinx/ReST
- miniterm application extended (CTRL+T -> menu)
- miniterm.py is now installed as "script"
- add scanlinux.py example
- add port_publisher example
-- experimental RFC-2217 client support (serial.rfc2217.Serial, see docs)
- experimental RFC-2217 server support (examples/rfc2217_server.py)
-- add ``serial.serial_for_url`` factory function (support for native ports and
- ``rfc2217``, ``socket`` and ``loop`` URLs)
- add ``getSettingsDict`` and ``applySettingsDict`` serial object methods
-- use a ``poll`` based implementation on Linux, instead of a ``select``based
- like on other posix systems. It provides better error handling, but ``poll``
- is not supported well on all platforms.
+- use a ``poll`` based implementation on Posix, instead of a ``select`` based,
+ provides better error handling.
Bugfixes:
@@ -337,4 +332,41 @@ Bugfixes (win32):
- [SF 2446218] outWaiting implemented
- [Bug 2392892] scanwin32.py better exception handling
- [Bug 2505422] scanwin32.py Vista 64bit compatibility
+
+
+Version 2.5-rc2 2010-01-02
+---------------------------
+New Features:
+
+- Documentation update, now written with Sphinx/ReST
+- Updated miniterm.py example
+- experimental RFC-2217 client support (serial.rfc2217.Serial, see docs)
+- add ``loop://`` device for testing.
+- add ``serial.serial_for_url`` factory function (support for native ports and
+ ``rfc2217``, ``socket`` and ``loop`` URLs)
+- add new example: ``rfc2217_server.py``
+- tests live in their own directory now (no longer in examples)
+
+Bugfixes:
+
+- [Bug 2915810] Fix for suboption parsing in rfc2217
+- Packaging bug (missed some files)
+
+Bugfixes (posix):
+
+- improve write timeout behavior
+- [Bug 2836297] move Linux specific constants to not break other platforms
+- ``poll`` based implementation for ``read`` is in a separate class
+ ``PosixPollSerial``, as it is not supported well on all platforms (the
+ default ``Serial`` class uses select).
+- changed error handling in ``read`` so that disconnected devices are
+ detected.
+
+
+Bugfixes (win32):
+
- [Bug 2886763] hComPort doesn't get initialized for Serial(port=None)
+
+
+Version 2.5 <date>
+---------------------------
diff --git a/pyserial/README.txt b/pyserial/README.txt
index 7767da3..d256f67 100644
--- a/pyserial/README.txt
+++ b/pyserial/README.txt
@@ -14,7 +14,7 @@ automatically selects the appropriate backend.
- SVN repository: http://sourceforge.net/svn/?group_id=46487
- Download Page: http://sourceforge.net/project/showfiles.php?group_id=46487
-BSD license, (C) 2001-2009 Chris Liechti <cliechti@gmx.net>
+BSD license, (C) 2001-2010 Chris Liechti <cliechti@gmx.net>
Documentation
diff --git a/pyserial/serial/__init__.py b/pyserial/serial/__init__.py
index b888702..d46e717 100644
--- a/pyserial/serial/__init__.py
+++ b/pyserial/serial/__init__.py
@@ -3,10 +3,10 @@
# portable serial port access with python
# this is a wrapper module for different platform implementations
#
-# (C) 2001-2009 Chris Liechti <cliechti@gmx.net>
+# (C) 2001-2010 Chris Liechti <cliechti@gmx.net>
# this is distributed under a free software license, see license.txt
-VERSION = '2.5'
+VERSION = '2.5-rc2'
import sys
diff --git a/pyserial/setup.py b/pyserial/setup.py
index b4a2fba..cd71ce7 100644
--- a/pyserial/setup.py
+++ b/pyserial/setup.py
@@ -28,7 +28,7 @@ if sys.version < '2.3':
setup(
name = "pyserial" + suffix,
description = "Python Serial Port Extension",
- version = "2.5-rc1",
+ version = "2.5-rc2",
author = "Chris Liechti",
author_email = "cliechti@gmx.net",
url = "http://pyserial.sourceforge.net/",