summaryrefslogtreecommitdiff
path: root/CHANGES.rst
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2015-12-27 21:00:25 +0100
committerChris Liechti <cliechti@gmx.net>2015-12-27 21:00:25 +0100
commitb5f31826f9f77ee569deed5304f8e83ed6dbe1ff (patch)
treefb2d17256ea18718ebc8ce5b2ea7039861791729 /CHANGES.rst
parent147b08d1a14899bc6fa8759cb311dc8fd38ac963 (diff)
downloadpyserial-git-b5f31826f9f77ee569deed5304f8e83ed6dbe1ff.tar.gz
doc update
Diffstat (limited to 'CHANGES.rst')
-rw-r--r--CHANGES.rst13
1 files changed, 12 insertions, 1 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index b6f9332..756f172 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -562,9 +562,20 @@ Version 3.0b2 2015-11-xx
- minor fixes to setup.py (file list), inter_byte_timeout (not stored when
passed to __init__), rfc2217 (behavior of close when open failed),
- list_ports (__str__)
+ list_ports (__str__), loop://, renamed ReaderThread
+- hwgrep:// can pick n'th port, skip busy ports
+- miniterm: --ask option added
+
+Bugfixes (posix):
+
+- [#26/#30] always call tcsettattr on open
+- [#42] fix disregard read timeout if there is more data
+- [#45] check for write timeout, even if EAGAIN was rised
Bugfixes (win32):
- [#27] fix race condition in ``read()``, fix minimal timeout issue
+- race condition in nonblocking case
+- [#49] change exception type in case SetCommState fails
+- [#50] fixed issue with 0 timeout on windows 10