summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Liechti <cliechti@gmx.net>2016-03-18 23:01:49 +0100
committerChris Liechti <cliechti@gmx.net>2016-03-18 23:01:49 +0100
commit9852c30577b93d516566394f4388dacc5e9d7fe0 (patch)
tree154080b55d8b7ba6f973b2f217828e1a1a1e4a48 /setup.py
parent01df889edcd34aee60e0950513e479e9e9cb4e52 (diff)
downloadpyserial-git-9852c30577b93d516566394f4388dacc5e9d7fe0.tar.gz
doc: updates, license in setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index cc9bd1b..3314fa2 100644
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,5 @@
# setup.py for pySerial
#
-# Windows installer:
-# "python setup.py bdist_wininst"
-#
# Direct install (all systems):
# "python setup.py install"
#
@@ -18,8 +15,6 @@ try:
except ImportError:
from distutils.core import setup
-# importing version does not work with Python 3 as files have not yet been
-# converted.
import serial
version = serial.VERSION
@@ -31,7 +26,7 @@ setup(
author_email="cliechti@gmx.net",
url="https://github.com/pyserial/pyserial",
packages=['serial', 'serial.tools', 'serial.urlhandler', 'serial.threaded'],
- license="Python",
+ license="BSD",
long_description="Python Serial Port Extension for Win32, OSX, Linux, BSD, Jython, IronPython",
classifiers=[
'Development Status :: 5 - Production/Stable',