summaryrefslogtreecommitdiff
path: root/pyparallel/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'pyparallel/setup.py')
-rw-r--r--pyparallel/setup.py17
1 files changed, 11 insertions, 6 deletions
diff --git a/pyparallel/setup.py b/pyparallel/setup.py
index 64bda13..929277a 100644
--- a/pyparallel/setup.py
+++ b/pyparallel/setup.py
@@ -1,6 +1,16 @@
#!/usr/bin/env python
from distutils.core import setup, Extension
+import os
+if os.name == 'nt':
+ ext_modules =[
+ Extension('_pyparallel',
+ sources=['src/win32/_pyparallel.c'],
+ )
+ ]
+else:
+ ext_modules = None
+
setup (name = "pyparallel",
description="Python Parallel Port Extension",
version="0.1",
@@ -10,10 +20,5 @@ setup (name = "pyparallel",
packages=['parallel'],
license="Python",
long_description="Python Parallel Port Extension for Win32, Linux, BSD",
-
- ext_modules = [
- Extension('_pyparallel',
- sources=['src/win32/_pyparallel.c', 'src/win32/loaddrv.c'],
- )
- ]
+ ext_modules = ext_modules
)