summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2013-10-17 03:17:50 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2013-10-17 03:17:50 +0000
commitb5cea6bdf27a8d5114186339f92726d1b66ab581 (patch)
tree277a53bb6c93f8ad3f78fccb045b1c3de421f53e
parente0984e1bd7e8afc4c8f04d191a11ce87492fdf38 (diff)
downloadpyserial-b5cea6bdf27a8d5114186339f92726d1b66ab581.tar.gz
updates (links, typos, changes in 2.7, dates)
git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk/pyserial@481 f19166aa-fa4f-0410-85c2-fa1106f25c8a
-rw-r--r--documentation/appendix.rst2
-rw-r--r--documentation/examples.rst41
-rw-r--r--documentation/index.rst2
-rw-r--r--documentation/pyserial.rst48
-rw-r--r--documentation/pyserial_api.rst3
-rw-r--r--documentation/shortintro.rst4
6 files changed, 51 insertions, 49 deletions
diff --git a/documentation/appendix.rst b/documentation/appendix.rst
index 2c3a549..eaba1e8 100644
--- a/documentation/appendix.rst
+++ b/documentation/appendix.rst
@@ -82,7 +82,7 @@ com0com - http://com0com.sourceforge.net/
License
=======
-Copyright (C) 2001-2011 Chris Liechti <cliechti(at)gmx.net>;
+Copyright (C) 2001-2013 Chris Liechti <cliechti(at)gmx.net>;
All Rights Reserved.
This is the Python license. In short, you can use this product in commercial
diff --git a/documentation/examples.rst b/documentation/examples.rst
index 4ea35ed..181aa2c 100644
--- a/documentation/examples.rst
+++ b/documentation/examples.rst
@@ -108,8 +108,8 @@ setup-miniterm-py2exe.py_
This is a py2exe setup script for Windows. It can be used to create a
standalone ``miniterm.exe``.
-.. _miniterm.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/serial/tools/miniterm.py
-.. _setup-miniterm-py2exe.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/setup-miniterm-py2exe.py
+.. _miniterm.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/serial/tools/miniterm.py
+.. _setup-miniterm-py2exe.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/setup-miniterm-py2exe.py
TCP/IP - serial bridge
@@ -177,7 +177,8 @@ below gives the client much more control over the remote serial port.
tcp_serial_redirect.py_
Main program.
-.. _tcp_serial_redirect.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/tcp_serial_redirect.py
+.. _tcp_serial_redirect.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/tcp_serial_redirect.py
+
Single-port TCP/IP - serial bridge (RFC 2217)
=============================================
@@ -217,8 +218,8 @@ setup-rfc2217_server-py2exe.py_
This is a py2exe setup script for Windows. It can be used to create a
standalone ``rfc2217_server.exe``.
-.. _rfc2217_server.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/rfc2217_server.py
-.. _setup-rfc2217_server-py2exe.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/setup-rfc2217_server-py2exe.py
+.. _rfc2217_server.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/rfc2217_server.py
+.. _setup-rfc2217_server-py2exe.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/setup-rfc2217_server-py2exe.py
Multi-port TCP/IP - serial bridge (RFC 2217)
@@ -266,8 +267,8 @@ port_publisher.py_
port_publisher.sh_
Example init.d script.
-.. _port_publisher.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/port_publisher.py
-.. _port_publisher.sh: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/port_publisher.sh
+.. _port_publisher.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/port_publisher.py
+.. _port_publisher.sh: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/port_publisher.sh
wxPython examples
@@ -291,11 +292,11 @@ wxSerialConfigDialog.wxg_
setup-wxTerminal-py2exe.py_
A py2exe setup script to package the terminal application.
-.. _wxTerminal.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/wxTerminal.py
-.. _wxTerminal.wxg: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/wxTerminal.wxg
-.. _wxSerialConfigDialog.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/wxSerialConfigDialog.py
-.. _wxSerialConfigDialog.wxg: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/wxSerialConfigDialog.wxg
-.. _setup-wxTerminal-py2exe.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/setup-wxTerminal-py2exe.py
+.. _wxTerminal.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/wxTerminal.py
+.. _wxTerminal.wxg: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/wxTerminal.wxg
+.. _wxSerialConfigDialog.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/wxSerialConfigDialog.py
+.. _wxSerialConfigDialog.wxg: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/wxSerialConfigDialog.wxg
+.. _setup-wxTerminal-py2exe.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/setup-wxTerminal-py2exe.py
Wrapper class
@@ -306,7 +307,7 @@ implementation of ``readline()``
enhancedserial.py_
A class with alternative ``readline()`` implementation.
-.. _enhancedserial.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/examples/enhancedserial.py
+.. _enhancedserial.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/examples/enhancedserial.py
Unit tests
@@ -341,10 +342,10 @@ test_iolib.py_
test_url.py_
Tests involving the :ref:`URL <URLs>` feature.
-.. _run_all_tests.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/test/run_all_tests.py
-.. _test.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/test/test.py
-.. _test_advanced.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/test/test_advanced.py
-.. _test_high_load.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/test/test_high_load.py
-.. _test_readline.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/test/test_readline.py
-.. _test_iolib.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/test/test_iolib.py
-.. _test_url.py: http://pyserial.svn.sourceforge.net/viewvc/*checkout*/pyserial/trunk/pyserial/test/test_url.py
+.. _run_all_tests.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/test/run_all_tests.py
+.. _test.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/test/test.py
+.. _test_advanced.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/test/test_advanced.py
+.. _test_high_load.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/test/test_high_load.py
+.. _test_readline.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/test/test_readline.py
+.. _test_iolib.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/test/test_iolib.py
+.. _test_url.py: http://sourceforge.net/p/pyserial/code/HEAD/tree/trunk/pyserial/test/test_url.py
diff --git a/documentation/index.rst b/documentation/index.rst
index ed306ba..9226aee 100644
--- a/documentation/index.rst
+++ b/documentation/index.rst
@@ -16,7 +16,7 @@ Other pages (online)
- This page, when viewed online, is at http://pyserial.sf.net.
.. _`project page on SourceForge`: http://sourceforge.net/projects/pyserial/
-.. _`SVN repository`: http://sourceforge.net/svn/?group_id=46487
+.. _`SVN repository`: http://svn.code.sf.net/p/pyserial/code/trunk
.. _`Download Page`: http://pypi.python.org/pypi/pyserial
diff --git a/documentation/pyserial.rst b/documentation/pyserial.rst
index 69076b8..bedef79 100644
--- a/documentation/pyserial.rst
+++ b/documentation/pyserial.rst
@@ -12,19 +12,19 @@ automatically selects the appropriate backend.
It is released under a free software license, see LICENSE_ for more
details.
-Copyright (C) 2001-2010 Chris Liechti <cliechti(at)gmx.net>
+Copyright (C) 2001-2013 Chris Liechti <cliechti(at)gmx.net>
Other pages (online)
- `project page on SourceForge`_
- `SVN repository`_
-- `Download Page`_ with releases
+- `Download Page`_ with releases (PyPi)
- This page, when viewed online is at http://pyserial.sf.net.
.. _LICENSE: appendix.html#license
.. _`project page on SourceForge`: http://sourceforge.net/projects/pyserial/
-.. _`SVN repository`: http://sourceforge.net/svn/?group_id=46487
-.. _`Download Page`: http://sourceforge.net/project/showfiles.php?group_id=46487
+.. _`SVN repository`: http://svn.code.sf.net/p/pyserial/code/trunk
+.. _`Download Page`: http://pypi.python.org/pypi/pyserial
Features
@@ -46,7 +46,7 @@ Features
Requirements
============
- Python 2.3 or newer, including Python 3.x
-- ctypes extensions on Windows (is in standard library since Python 2.5+)
+- ctypes extension on Windows (is in standard library since Python 2.5+)
- "Java Communications" (JavaComm) or compatible extension for Java/Jython
@@ -57,8 +57,19 @@ pyserial
--------
This installs a package that can be used from Python (``import serial``).
-To install the module for all users on the system, administrator rights (root)
-is required..
+To install for all users on the system, administrator rights (root)
+may be required.
+
+From PyPI
+~~~~~~~~~
+pySerial can be installed from PyPI, either manually downloading the
+files and installing as described below or using::
+
+ pip install pyserial
+
+or::
+
+ easy_install -U pyserial
From source (tar.gz or checkout)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
@@ -71,29 +82,18 @@ For Python 3.x::
python3 setup.py install
-From PyPI
-~~~~~~~~~
-Alternatively it can be installed from PyPI, either manually downloading the
-files and installing as described above or using::
-
- pip install pyserial
-
-or::
-
- easy_install -U pyserial
-
Packages
~~~~~~~~
There are also packaged versions for some Linux distributions and Windows:
Debian/Ubuntu
A package is available under the name "python-serial". Note that some
- distributions package an older version of pySerial.
+ distributions may package an older version of pySerial.
Windows
There is also a Windows installer for end users. It is located in the
- PyPi_. Developers may be interested to get the source archive, because it
- contains examples and the readme.
+ PyPi_. Developers also may be interested to get the source archive,
+ because it contains examples, tests and the this documentation.
.. _PyPi: http://pypi.python.org/pypi/pyserial
@@ -111,12 +111,12 @@ References
Older Versions
==============
-Older versions are still available on the `Download Page`_. pySerial 1.21 is
-compatible with Python 2.0 on Windows, Linux and several un*x like systems,
+Older versions are still available in the old download_ page. pySerial 1.21
+is compatible with Python 2.0 on Windows, Linux and several un*x like systems,
MacOSX and Jython.
On windows releases older than 2.5 will depend on pywin32_ (previously known as
win32all)
-.. _`Download Page`: http://sourceforge.net/project/showfiles.php?group_id=46487
+.. _download: http://sourceforge.net/projects/pyserial/files/pyserial/
.. _pywin32: http://pypi.python.org/pypi/pywin32
diff --git a/documentation/pyserial_api.rst b/documentation/pyserial_api.rst
index c5a0f5b..f6117d1 100644
--- a/documentation/pyserial_api.rst
+++ b/documentation/pyserial_api.rst
@@ -687,7 +687,7 @@ Exceptions
Base class for serial port exceptions.
.. versionchanged:: 2.5
- Now derrives from :exc:`IOError` instead of :exc:`Exception`
+ Now derives from :exc:`IOError` instead of :exc:`Exception`
.. exception:: SerialTimeoutException
@@ -940,6 +940,7 @@ serial.tools.list_ports``). It also contains the following functions.
:platform: Posix (/dev files)
:platform: Linux (/dev files, sysfs and lsusb)
+ :platform: OSX (iokit)
:platform: Windows (setupapi, registry)
diff --git a/documentation/shortintro.rst b/documentation/shortintro.rst
index b9a8a8c..2d9dd1b 100644
--- a/documentation/shortintro.rst
+++ b/documentation/shortintro.rst
@@ -9,7 +9,7 @@ Open port 0 at "9600,8,N,1", no timeout::
>>> import serial
>>> ser = serial.Serial(0) # open first serial port
- >>> print ser.portstr # check which port was really used
+ >>> print ser.name # check which port was really used
>>> ser.write("hello") # write a string
>>> ser.close() # close port
@@ -99,6 +99,6 @@ include entries that matched.
Accessing ports
---------------
-pySerial includes a small terminal console based terminal program called
+pySerial includes a small console based terminal program called
:ref:`miniterm`. It ca be started with ``python -m serial.tools.miniterm <port name>``
(use option ``-h`` to get a listing of all options).