summaryrefslogtreecommitdiff
path: root/README.txt
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-11-06 22:17:21 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-11-06 22:17:21 +0000
commitf95f2b719d401a94bfcaa84f55530888d125c5f7 (patch)
treea1699f3d6698c2665092a0580e44daa3de10a7d1 /README.txt
parent2d5d57bb76802b251a2d2f693930597872857c45 (diff)
downloadpyserial-f95f2b719d401a94bfcaa84f55530888d125c5f7.tar.gz
2.0 release
changed the setup.py version hack to the recomended code in the distutils docs git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk/pyserial@101 f19166aa-fa4f-0410-85c2-fa1106f25c8a
Diffstat (limited to 'README.txt')
-rw-r--r--README.txt18
1 files changed, 15 insertions, 3 deletions
diff --git a/README.txt b/README.txt
index 3b0de93..b476eb3 100644
--- a/README.txt
+++ b/README.txt
@@ -15,11 +15,12 @@ Project Homepage: pyserial.sourceforge.net
Features
--------
- same class based interface on all supported platforms
+- access to the port settings trough Python 2.2 properties
- port numbering starts at zero, no need to know the platform dependant port
name in the user program
- port name can be specified if access through numbering is inappropriate
- support for different bytesizes, stopbits, parity and flow control
- with RTS/CTS and/or xon/xoff
+ with RTS/CTS and/or Xon/Xoff
- working with or without receive timeout, blocking or non-blocking
- file like API with "read" and "write" ("readline" etc. also supported)
- The files in this package are 100% pure Python.
@@ -45,6 +46,12 @@ let Distutils do the rest: "python setup.py install"
The files get installed in the "Lib/site-packages" directory.
+There is also a Windows installer, but for developers it may be interesting
+to get the source archive anyway, because it contains examples and the readme.
+
+Do also have a look at the example files in the examples directory in the
+source distribution or online in CVS repository.
+
Serial to USB adapters
----------------------
Such adapters are reported to work under Mac OSX and Windows. They are
@@ -128,7 +135,9 @@ ser = serial.Serial(
rtscts=0, #enable RTS/CTS flow control
)
-The port is immediately opened on object creation.
+The port is immediately opened on object creation, if a port is given.
+It is not opened if port is None.
+
Options for read timeout:
timeout=None #wait forever
timeout=0 #non-blocking mode (return immediately on read)
@@ -169,9 +178,12 @@ bytesize #bytesize in bits
parity #parity setting
stopbits #stop bit with (1,2)
timeout #timeout setting
-xonxoff #if XonXoff flow control is enabled
+xonxoff #if Xon/Xoff flow control is enabled
rtscts #if hardware flow control is enabled
+Exceptions
+----------
+serial.SerialException
Constants
---------