summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-21 19:48:41 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-21 19:48:41 +0000
commit0bccf18c469abcc27c2ebf50e0cda7349d893a5e (patch)
tree62489de3afbb4b6e6e0c8651b1db5a18a85b709c /setup.py
parent9063ab86edeb3e75af6c1c4b2c9f7cdeee0ecd6c (diff)
downloadpyserial-0bccf18c469abcc27c2ebf50e0cda7349d893a5e.tar.gz
minor changes
git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk/pyserial@214 f19166aa-fa4f-0410-85c2-fa1106f25c8a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 12 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 9f3b349..305dd89 100644
--- a/setup.py
+++ b/setup.py
@@ -19,15 +19,15 @@ if sys.version < '2.2.3':
DistributionMetadata.download_url = None
setup(
- name="pyserial",
- description="Python Serial Port Extension",
- version="2.4",
- author="Chris Liechti",
- author_email="cliechti@gmx.net",
- url="http://pyserial.sourceforge.net/",
- packages=['serial'],
- license="Python",
- long_description="Python Serial Port Extension for Win32, Linux, BSD, Jython",
+ name = "pyserial",
+ description = "Python Serial Port Extension",
+ version = "2.4",
+ author = "Chris Liechti",
+ author_email = "cliechti@gmx.net",
+ url = "http://pyserial.sourceforge.net/",
+ packages = ['serial'],
+ license = "Python",
+ long_description = "Python Serial Port Extension for Win32, Linux, BSD, Jython, IronPython",
classifiers = [
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
@@ -41,4 +41,7 @@ setup(
'Topic :: Software Development :: Libraries',
'Topic :: Terminals :: Serial',
],
+ platforms = 'any',
+ #~ scripts = ['scripts/python-miniterm'],
+)
)