summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-30 17:27:48 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-30 17:27:48 +0000
commit74dcc571893d135bfc74d1d3cbc1118fe2082ac5 (patch)
tree83054af718ab0632f18782fd7679fcbde16e2a78 /setup.py
parent5811fb5fa0228b0ebeb287f95c93fdc4b6803c96 (diff)
downloadpyserial-74dcc571893d135bfc74d1d3cbc1118fe2082ac5.tar.gz
add py3k suffix when processing with the 2to3 conversion (mainly for bdist_wininst)
git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk/pyserial@262 f19166aa-fa4f-0410-85c2-fa1106f25c8a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 71fb0f7..03ff8e3 100644
--- a/setup.py
+++ b/setup.py
@@ -13,6 +13,10 @@ except ImportError:
if sys.version_info >= (3, 0):
raise ImportError("build_py_2to3 not found in distutils - it is required for Python 3.x")
from distutils.command.build_py import build_py
+ suffix = ""
+else:
+ suffix = "-py3k"
+
if sys.version < '2.3':
# distutils that old can't cope with the "classifiers" or "download_url"
@@ -22,7 +26,7 @@ if sys.version < '2.3':
"releases or upgrade your Python installation.")
setup(
- name = "pyserial",
+ name = "pyserial" + suffix,
description = "Python Serial Port Extension",
version = "2.4",
author = "Chris Liechti",