summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-25 03:44:33 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2009-07-25 03:44:33 +0000
commit9b12562f15ac2cffc06fada3d19db679ae9bf259 (patch)
treeb9f35aeb97279b707c08080c3b94e6594d82440f /setup.py
parentfdf8367b8d2d9ced7ccf0349afd476552f6e71ce (diff)
downloadpyserial-9b12562f15ac2cffc06fada3d19db679ae9bf259.tar.gz
- add more methods for file-like compatibility
- provide RawSerial when io library is present (not yet finished) -> changes internal class hierarchy -> renamed internal read/write -> _read/_write (FileLike resp. RawSerialBase provides read/write) -> add test_rawio.py - _write returns number of byte written - set minimal python version to 2.3 due to basestring - add "name" attribute - documentation updates (new io stuff and VERSION, device()) git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk/pyserial@249 f19166aa-fa4f-0410-85c2-fa1106f25c8a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index f9c41ef..4198f32 100644
--- a/setup.py
+++ b/setup.py
@@ -14,9 +14,9 @@ except ImportError:
raise ImportError("build_py_2to3 not found in distutils - it is required for Python 3.x")
from distutils.command.build_py import build_py
-if sys.version < '2.2.3':
- # distutils that old can't cope with the "classifiers" or
- # "download_url" keywords and True/False constants are missing
+if sys.version < '2.3':
+ # distutils that old can't cope with the "classifiers" or "download_url"
+ # keywords and True/False constants and basestring are missing
raise ValueError("Sorry Python versions older than 2.2.3 are no longer"
"supported - check http://pyserial.sf.net for older "
"releases or upgrade your Python installation.")