summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2011-03-18 11:16:15 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2011-03-18 11:16:15 +0000
commite75f543f968817c02446bc84ec8c15c64d396adf (patch)
tree849055a6fcdf3924269fb792c5438e6c21c0c468 /setup.py
parente70b802b00f61b3428adaa76dae52bbca47e89b5 (diff)
downloadpyserial-e75f543f968817c02446bc84ec8c15c64d396adf.tar.gz
automatically set version
git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk/pyserial@391 f19166aa-fa4f-0410-85c2-fa1106f25c8a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1820fc0..8776361 100644
--- a/setup.py
+++ b/setup.py
@@ -33,10 +33,12 @@ if sys.version < '2.3':
"supported - check http://pyserial.sf.net for older "
"releases or upgrade your Python installation.")
+import serial
+
setup(
name = "pyserial" + suffix,
description = "Python Serial Port Extension",
- version = "2.6pre",
+ version = serial.VERSION,
author = "Chris Liechti",
author_email = "cliechti@gmx.net",
url = "http://pyserial.sourceforge.net/",