summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorcliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-11-06 22:17:21 +0000
committercliechti <cliechti@f19166aa-fa4f-0410-85c2-fa1106f25c8a>2003-11-06 22:17:21 +0000
commitf95f2b719d401a94bfcaa84f55530888d125c5f7 (patch)
treea1699f3d6698c2665092a0580e44daa3de10a7d1 /setup.py
parent2d5d57bb76802b251a2d2f693930597872857c45 (diff)
downloadpyserial-f95f2b719d401a94bfcaa84f55530888d125c5f7.tar.gz
2.0 release
changed the setup.py version hack to the recomended code in the distutils docs git-svn-id: http://svn.code.sf.net/p/pyserial/code/trunk/pyserial@101 f19166aa-fa4f-0410-85c2-fa1106f25c8a
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 10 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 59c7467..6d109f9 100644
--- a/setup.py
+++ b/setup.py
@@ -1,20 +1,28 @@
# setup.py
from distutils.core import setup
+import sys
#windows installer:
# python setup.py bdist_wininst
+# patch distutils if it can't cope with the "classifiers" or
+# "download_url" keywords
+if sys.version < '2.2.3':
+ from distutils.dist import DistributionMetadata
+ DistributionMetadata.classifiers = None
+ DistributionMetadata.download_url = None
+
setup(
name="pyserial",
description="Python Serial Port Extension",
- version="2.0b2",
+ version="2.0",
author="Chris Liechti",
author_email="cliechti@gmx.net",
url="http://pyserial.sourceforge.net/",
packages=['serial'],
license="Python",
long_description="Python Serial Port Extension for Win32, Linux, BSD, Jython",
- classifiers=[
+ classifiers = [
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
'Intended Audience :: End Users/Desktop',