summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt16
-rw-r--r--README.txt8
-rw-r--r--serial/serialwin32.py2
-rw-r--r--setup.py2
4 files changed, 17 insertions, 11 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 384dd10..a51413a 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -257,7 +257,7 @@ Bugfixes:
- update VERSION variable
- update wxSerialConfigDialog.py and wxTerminal.py compatibility with
wxPython 2.8 (Peleg)
-- Check for string in write function. Using uncode causes strange errors, this
+- Check for string in write function. Using unicode causes errors, this
helps catching errors early (Tom Lynn)
Bugfixes (posix):
@@ -269,20 +269,18 @@ Bugfixes (posix):
Bugfixes (win32):
- [Bug 1520357] Handle leak
-- [Bug 1679013] Ignore excpetion raised by SetCommTimeout() in close().
+- [Bug 1679013] Ignore exception raised by SetCommTimeout() in close().
- [Bug 1938118] process hang forever under XP
-Version 2.4
+Version 2.4 6 Jul 2008
---------------------------
New Features:
- [Patch 1616790] pyserial: Add inter-character timeout feature
- [Patch 1924805] add a setBreak function
- Add mark/space parity
-- Add .NET/Mono backend (IronPython).
-
-Bugfixes:
+- Add .NET/Mono backend (IronPython)
Bugfixes (posix):
@@ -291,5 +289,11 @@ Bugfixes (posix):
Bugfixes (win32):
- [Patch 1561423] Add mark/space parity, Win32
+- [Bug 2000771] serial port CANNOT be specified by number on windows
- examples/scanwin32.py does no longer return \\.\ names
- fix \\.\ handling for some cases
+
+Bugfixes (jython):
+
+ - The Jython backend tries javax.comm and gnu.io (Seo Sanghyeon)
+
diff --git a/README.txt b/README.txt
index 2accdd3..ce26437 100644
--- a/README.txt
+++ b/README.txt
@@ -3,14 +3,14 @@ pySerial
========
This module capsulates the access for the serial port. It provides backends
for standard Python running on Windows, Linux, BSD (possibly any POSIX
-compilant system) and Jython. The module named "serial" automaticaly selects
-the appropriate backend.
+compilant system), Jython and IronPython. The module named "serial"
+automaticaly selects the appropriate backend.
It is released under a free software license, see LICENSE.txt for more
details.
Project Homepage: http://pyserial.sourceforge.net
-(C) 2001-2005 Chris Liechti <cliechti@gmx.net>
+(C) 2001-2008 Chris Liechti <cliechti@gmx.net>
Features
@@ -274,3 +274,5 @@ References
- Java@IBM http://www-106.ibm.com/developerworks/java/jdk/
(JavaComm links are on the download page for the respective platform jdk)
- Java@SUN http://java.sun.com/products/
+- IronPython: http://www.codeplex.com/IronPython
+- setuptools: http://peak.telecommunity.com/DevCenter/setuptools
diff --git a/serial/serialwin32.py b/serial/serialwin32.py
index 94371c1..f5e8961 100644
--- a/serial/serialwin32.py
+++ b/serial/serialwin32.py
@@ -76,7 +76,7 @@ class Serial(SerialBase):
self._isOpen = True
def _reconfigurePort(self):
- """Set commuication parameters on opened port."""
+ """Set communication parameters on opened port."""
if not self.hComPort:
raise SerialException("Can only operate on a valid port handle")
diff --git a/setup.py b/setup.py
index a885d8f..9f3b349 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ if sys.version < '2.2.3':
setup(
name="pyserial",
description="Python Serial Port Extension",
- version="2.3",
+ version="2.4",
author="Chris Liechti",
author_email="cliechti@gmx.net",
url="http://pyserial.sourceforge.net/",