summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.txt16
-rw-r--r--LICENSE.txt2
-rw-r--r--documentation/pyserial_api.rst14
-rw-r--r--setup.py3
4 files changed, 32 insertions, 3 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 01193c9..867a432 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -370,3 +370,19 @@ Bugfixes (win32):
Version 2.5 <date>
---------------------------
+New Features:
+
+- [Bug 2976262] dsrdtr should default to False
+ ``dsrdtr`` parameter default value changed from ``None`` (follow ``rtscts``
+ setting) to ``False``. This means ``rtscts=True`` enables hardware flow
+ control on RTS/CTS but no longer also on DTR/DSR. This change mostly
+ affects Win32 as on other platforms, that setting was ignored anyway.
+
+Bugfixes:
+
+- [Bug 2925854] test.py produces exception with python 3.1
+
+Bugfixes (win32):
+
+- [Bug 2998169] Memory corruption at faster transmission speeds.
+
diff --git a/LICENSE.txt b/LICENSE.txt
index e8664f4..6462232 100644
--- a/LICENSE.txt
+++ b/LICENSE.txt
@@ -1,4 +1,4 @@
-Copyright (c) 2001-2008 Chris Liechti <cliechti@gmx.net>;
+Copyright (c) 2001-2010 Chris Liechti <cliechti@gmx.net>;
All Rights Reserved.
This is the Python license. In short, you can use this product in
diff --git a/documentation/pyserial_api.rst b/documentation/pyserial_api.rst
index d8566e3..14f1848 100644
--- a/documentation/pyserial_api.rst
+++ b/documentation/pyserial_api.rst
@@ -12,7 +12,7 @@ Native ports
.. class:: Serial
- .. method:: __init__(port=None, baudrate=9600, bytesize=EIGHTBITS, parity=PARITY_NONE, stopbits=STOPBITS_ONE, timeout=None, xonxoff=0, rtscts=0, interCharTimeout=None)
+ .. method:: __init__(port=None, baudrate=9600, bytesize=EIGHTBITS, parity=PARITY_NONE, stopbits=STOPBITS_ONE, timeout=None, xonxoff=0, rtscts=0, writeTimeout=None, dsrdtr=False, interCharTimeout=None)
:param port:
Device name or port number number or :const:`None`.
@@ -44,6 +44,12 @@ Native ports
:param rtscts:
Enable hardware (RTS/CTS) flow control.
+ :param dsrdtr:
+ Enable hardware (DSR/DTR) flow control.
+
+ :param writeTimeout:
+ Set a write timeout value.
+
:param interCharTimeout:
Inter-character timeout, :const:`None` to disable (default).
@@ -70,10 +76,16 @@ Native ports
- ``timeout = 0``: non-blocking mode (return immediately on read)
- ``timeout = x``: set timeout to ``x`` seconds (float allowed)
+ Writes are blocking by default unless *writeTimeout* is set. For possible
+ values refer to the list for *timeout* above.
+
Note that enabling both flow control methods (*xonxoff* and *rtscts*)
together may not be supported. It is common to use one of the methods
at once, not both.
+ *dsrdtr* is not supported by all platforms (silently ignored). Setting
+ it to ``None`` has the effect that its state follows *rtscts*.
+
.. method:: open()
Open port.
diff --git a/setup.py b/setup.py
index cd71ce7..353ffdc 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ if sys.version < '2.3':
setup(
name = "pyserial" + suffix,
description = "Python Serial Port Extension",
- version = "2.5-rc2",
+ version = "2.5",
author = "Chris Liechti",
author_email = "cliechti@gmx.net",
url = "http://pyserial.sourceforge.net/",
@@ -50,6 +50,7 @@ setup(
'Programming Language :: Python :: 2.4',
'Programming Language :: Python :: 2.5',
'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.0',
'Programming Language :: Python :: 3.1',