summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2016-03-12 10:08:18 +0100
committerIlya Etingof <etingof@gmail.com>2016-03-12 10:08:18 +0100
commit98b42276e09cd4027e63c79f3ff73fd7f9f126a2 (patch)
tree896112d06cd3e25d559b436784b92e6d930c19b6 /.travis.yml
parentfc9925bc33ae2df02d045488d057f57b8788ca52 (diff)
downloadpysnmp-git-98b42276e09cd4027e63c79f3ff73fd7f9f126a2.tar.gz
travis added
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml19
1 files changed, 19 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 00000000..e4486081
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,19 @@
+
+language: python
+python:
+ - "2.6"
+ - "2.7"
+ - "3.2"
+ - "3.3"
+ - "3.4"
+ - "3.5"
+ - "nightly"
+ - "pypy"
+ - "pypy3"
+install:
+ - pip install pyasn1
+ - pip install pycrypto
+ - pip install pysmi
+ - python setup.py install
+script:
+ - sh runtests.sh