summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2018-08-06 23:22:48 +0200
committerIlya Etingof <etingof@gmail.com>2018-08-06 23:38:15 +0200
commit1b240862ed4a26ea0cca03cb84a133e39125ae43 (patch)
tree196d46bf2df1d7c09e7013564db7c6e370287607 /setup.py
parentd662c557a78194cdfa1992c77e6e98f8f0ed478c (diff)
downloadpysnmp-git-1b240862ed4a26ea0cca03cb84a133e39125ae43.tar.gz
Improve long description in Trove
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index eb59205d..412e667a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,9 +1,9 @@
#!/usr/bin/env python
"""SNMP library for Python
- SNMP v1/v2c/v3 engine and apps written in pure-Python.
- Supports Manager/Agent/Proxy roles, scriptable MIBs,
- asynchronous operation and multiple transports.
+SNMP v1/v2c/v3 engine and Standard Applications suite written in pure-Python.
+Supports Manager/Agent/Proxy roles, Manager/Agent-side MIBs, asynchronous
+operation and multiple network transports.
"""
import sys
import os
@@ -124,13 +124,13 @@ except ImportError:
re.sub(r'(.*?)([<>=!~]+)(.*)', r'\g<1>\g<2>(\g<3>)', r) for r in resolved_requires
]
-doclines = [x.strip() for x in (__doc__ or '').split('\n') if x]
+doclines = [x.strip() for x in (__doc__ or '').split('\n')]
params.update({
'name': 'pysnmp',
'version': open(os.path.join('pysnmp', '__init__.py')).read().split('\'')[1],
'description': doclines[0],
- 'long_description': ' '.join(doclines[1:]),
+ 'long_description': '\n'.join(doclines[1:]),
'maintainer': 'Ilya Etingof <etingof@gmail.com>',
'author': 'Ilya Etingof',
'author_email': 'etingof@gmail.com',