summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2013-01-06 21:20:00 +0000
committerelie <elie>2013-01-06 21:20:00 +0000
commit1f1542160e8da6dfcbdb4344a0c14880e55e52c6 (patch)
tree1a9da0e07e18fb711dd8cbb8352cef7e21d91d2a /setup.py
parent45ccc427238ac1099151003f7a4d45279af72749 (diff)
downloadpysnmp-git-1f1542160e8da6dfcbdb4344a0c14880e55e52c6.tar.gz
use platform-neutral paths
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 67d09038..610fd824 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,12 @@
#!/usr/bin/env python
-"""SNMP framework
+"""SNMP library for Python
SNMP v1/v2c/v3 engine and apps written in pure-Python.
Supports Manager/Agent/Proxy roles, scriptable MIBs,
asynchronous operation and multiple transports.
"""
import sys
+import os
classifiers = """\
Development Status :: 5 - Production/Stable
@@ -89,7 +90,7 @@ doclines = [ x.strip() for x in __doc__.split('\n') if x ]
params.update( {
'name': 'pysnmp',
- 'version': open('pysnmp/__init__.py').read().split('\'')[1],
+ 'version': open(os.path.join('pysnmp','__init__.py')).read().split('\'')[1],
'description': doclines[0],
'long_description': ' '.join(doclines[1:]),
'maintainer': 'Ilya Etingof <ilya@glas.net>',
@@ -125,7 +126,8 @@ params.update( {
'pysnmp.proto.acmod',
'pysnmp.proto.proxy',
'pysnmp.proto.api' ],
- 'scripts': [ 'tools/libsmi2pysnmp', 'tools/build-pysnmp-mib' ]
+ 'scripts': [ os.path.join('tools','libsmi2pysnmp'),
+ os.path.join('tools', 'build-pysnmp-mib') ]
} )
setup(**params)