summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2019-02-10 18:30:59 +0100
committerGitHub <noreply@github.com>2019-02-10 18:30:59 +0100
commit5c64b499c2cf6f168970aa7ae51fe4997cdd89fc (patch)
tree54a6e95198f22cf293923406f46f4eacc0f10155 /setup.py
parentcc2632d6d5c0096e0b563fb15750562c281af1eb (diff)
downloadpysnmp-git-5c64b499c2cf6f168970aa7ae51fe4997cdd89fc.tar.gz
Officially remove Python < 2.6 support (#239)
Perhaps previous commits have already broken older Python support. This commit mostly declares Python 2.6+ support.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 0ccc2376..317487d4 100644
--- a/setup.py
+++ b/setup.py
@@ -21,8 +21,6 @@ License :: OSI Approved :: BSD License
Natural Language :: English
Operating System :: OS Independent
Programming Language :: Python :: 2
-Programming Language :: Python :: 2.4
-Programming Language :: Python :: 2.5
Programming Language :: Python :: 2.6
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
@@ -53,8 +51,8 @@ def howto_install_setuptools():
py_version = sys.version_info[:2]
-if py_version < (2, 4):
- print("ERROR: this package requires Python 2.4 or later!")
+if py_version < (2, 6):
+ print("ERROR: this package requires Python 2.6 or later!")
sys.exit(1)
requires = [ln.strip() for ln in open('requirements.txt').readlines()]
@@ -159,7 +157,6 @@ params.update({
'pysnmp.hlapi.v3arch.asyncio',
'pysnmp.hlapi.v3arch.asyncore',
'pysnmp.hlapi.v3arch.asyncore.sync',
- 'pysnmp.hlapi.v3arch.asyncore.sync.compat',
'pysnmp.hlapi.v3arch.twisted',
'pysnmp.proto',
'pysnmp.proto.mpmod',