summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2013-09-21 09:45:36 +0000
committerelie <elie>2013-09-21 09:45:36 +0000
commita467f2632d90df9377562956595c4323fa689125 (patch)
treea8581e585abc0c9cd7be9a865c447d1cad78d0b9 /setup.py
parentfbad5472d8d40e28984d700500ce93c1aa915c9b (diff)
downloadpysnmp-git-a467f2632d90df9377562956595c4323fa689125.tar.gz
distribute is gone
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 3 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 610fd824..88893df7 100644
--- a/setup.py
+++ b/setup.py
@@ -28,25 +28,13 @@ Topic :: System :: Networking :: Monitoring
Topic :: Software Development :: Libraries :: Python Modules
"""
-def howto_install_distribute():
- print("""
- Error: You need the distribute Python package!
-
- It's very easy to install it, just type (as root on Linux):
-
- wget http://python-distribute.org/distribute_setup.py
- python distribute_setup.py
-
- Then you could make eggs from this package.
-""")
-
def howto_install_setuptools():
print("""
Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
- wget http://peak.telecommunity.com/dist/ez_setup.py
+ wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
python ez_setup.py
Then you could make eggs from this package.
@@ -63,11 +51,8 @@ try:
except ImportError:
for arg in sys.argv:
- if arg.find('egg') != -1:
- if sys.version_info[0] > 2:
- howto_install_distribute()
- else:
- howto_install_setuptools()
+ if 'egg' in arg:
+ howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
params = {}