summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIlya Etingof <etingof@gmail.com>2018-08-12 17:22:58 +0200
committerGitHub <noreply@github.com>2018-08-12 17:22:58 +0200
commitac0b956d006a4b7b32780e852740b56ecd826c7e (patch)
tree4576911add0e18525991109acdb2a91bc4b2fde8 /setup.py
parent488ec26798a4493ee0fc45e730f88f1365f56df7 (diff)
downloadpysnmp-git-ac0b956d006a4b7b32780e852740b56ecd826c7e.tar.gz
Add `hlapi.v1arch` API (#186)
* Add `hlapi.v1arch` API Introduce new sub-package `pysnmp.hlapi.v1arch` which wraps otherwise very detailed packet-level SNMP messaging into a handful of convenience functions. As a side effect, the `pysnmp.hlapi.*` sub-packages moved under `pysnmp.hlapi.v3arch` though `pysnmp.hlapi` still exposes `pysnmp.hlappi.v3arch.*` symbols to retain some degree of backward compatibility. The signature of the hlapi `.sendNotification()` call has changed to accept `*varBinds` instead of a sequence of `varBinds`. The rationale is to unify this method call with similar methods of CommandGenerator. * Add v1arch docs and reshuffle hlapi docs
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 412e667a..7b9df3fb 100644
--- a/setup.py
+++ b/setup.py
@@ -152,11 +152,14 @@ params.update({
'pysnmp.entity',
'pysnmp.entity.rfc3413',
'pysnmp.hlapi',
- 'pysnmp.hlapi.asyncio',
- 'pysnmp.hlapi.asyncore',
- 'pysnmp.hlapi.asyncore.sync',
- 'pysnmp.hlapi.asyncore.sync.compat',
- 'pysnmp.hlapi.twisted',
+ 'pysnmp.hlapi.v1arch',
+ 'pysnmp.hlapi.v1arch.asyncore',
+ 'pysnmp.hlapi.v3arch',
+ 'pysnmp.hlapi.v3arch.asyncio',
+ 'pysnmp.hlapi.v3arch.asyncore',
+ 'pysnmp.hlapi.v3arch.asyncore.sync',
+ 'pysnmp.hlapi.v3arch.asyncore.sync.compat',
+ 'pysnmp.hlapi.v3arch.twisted',
'pysnmp.proto',
'pysnmp.proto.mpmod',
'pysnmp.proto.secmod',