summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2012-07-23 16:57:15 +0000
committerelie <elie>2012-07-23 16:57:15 +0000
commitb37a59a2cbe032f6774e2c0d1d25f6b2d6199226 (patch)
treeb015ce0ebaca6ca1f3bb5b80c041de487d0d7da5 /setup.py
parent1429f5ab39858c297bcc39fd1c8533b37ae7e13d (diff)
downloadpysnmp-git-b37a59a2cbe032f6774e2c0d1d25f6b2d6199226.tar.gz
typo fixed
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 24 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index ef578eca..d00be1b4 100644
--- a/setup.py
+++ b/setup.py
@@ -20,19 +20,35 @@ Natural Language :: English
Operating System :: OS Independent
Programming Language :: Python :: 2
Programming Language :: Python :: 3
-Topic :: Communications,
+Topic :: Communications
Topic :: Software Development :: Libraries :: Python Modules
Topic :: System :: Monitoring
Topic :: System :: Networking :: Monitoring
Topic :: Software Development :: Libraries :: Python Modules
"""
+def howto_install_distribute():
+ print("""
+ Error: You need the distribute Python package!
+
+ It's very easy to install it, just type (as root on Linux):
+
+ wget http://python-distribute.org/distribute_setup.py
+ python distribute_setup.py
+
+ Then you could make eggs from this package.
+""")
+
def howto_install_setuptools():
- print("""Error: You need setuptools Python package!
+ print("""
+ Error: You need setuptools Python package!
+
+ It's very easy to install it, just type (as root on Linux):
-It's very easy to install it, just type (as root on Linux):
wget http://peak.telecommunity.com/dist/ez_setup.py
python ez_setup.py
+
+ Then you could make eggs from this package.
""")
try:
@@ -47,7 +63,10 @@ try:
except ImportError:
for arg in sys.argv:
if arg.find('egg') != -1:
- howto_install_setuptools()
+ if sys.version_info[0] > 2:
+ howto_install_distribute()
+ else:
+ howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
params = {}
@@ -70,7 +89,7 @@ doclines = [ x.strip() for x in __doc__.split('\n') if x ]
params.update( {
'name': 'pysnmp',
- 'version': open('pysnmp/__init__.py').read().split('\'')[1],
+ 'version': open('pysnmp/__init__.py').read().split('\'')[1]+'rc7',
'description': doclines[0],
'long_description': ' '.join(doclines[1:]),
'maintainer': 'Ilya Etingof <ilya@glas.net>',