summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--TODO.txt11
-rw-r--r--setup.py6
2 files changed, 13 insertions, 4 deletions
diff --git a/TODO.txt b/TODO.txt
index d8eac4fa..30a8699d 100644
--- a/TODO.txt
+++ b/TODO.txt
@@ -59,4 +59,13 @@ Sparse notes on major existing problems/plans
* Disallow empty SET value reaching scalar MIB object
-* Figure out why .getUnitis() are not propagated from SNMPv2-SMI::ObjectType to response object \ No newline at end of file
+* Figure out why .getUnitis() are not propagated from SNMPv2-SMI::ObjectType to response object
+
+* Extent pysmi/mibdump tool to produce MIB instances from ASN.1 MIBs
+
+* Write a tool that parses iana-private-enterprise numbers into a pysnmp MIB instance
+
+* Make mibdump producing OID->MIB indices in form of pysnmp MIB instance and JSON
+
+* Write a helper function/module based on pysnmp that reports device details based on SNMP data.
+ In particular: description, vendor ID/name (sysObjectID), implemented MIBs (sysORTable) \ No newline at end of file
diff --git a/setup.py b/setup.py
index 0c77601a..ea65eb0c 100644
--- a/setup.py
+++ b/setup.py
@@ -81,10 +81,10 @@ params.update({
'version': open(os.path.join('pysnmp', '__init__.py')).read().split('\'')[1],
'description': doclines[0],
'long_description': ' '.join(doclines[1:]),
- 'maintainer': 'Ilya Etingof <ilya@glas.net>',
+ 'maintainer': 'Ilya Etingof <etingof@gmail.com>',
'author': 'Ilya Etingof',
- 'author_email': 'ilya@glas.net',
- 'url': 'http://sourceforge.net/projects/pysnmp/',
+ 'author_email': 'etingof@gmail.com',
+ 'url': 'https://github.com/etingof/pysnmp',
'classifiers': [x for x in classifiers.split('\n') if x],
'platforms': ['any'],
'license': 'BSD',