summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorelie <elie>2011-07-22 09:28:12 +0000
committerelie <elie>2011-07-22 09:28:12 +0000
commit38fafc211c08e00f748c5bbfdcb63b827bc971a7 (patch)
treec5b68b49dbe89390ad50bb0ab055ed263803027f
parente1f94d4437718252128cf3d7398e67a637b93998 (diff)
downloadpysnmp-release_4_1_16b_tag.tar.gz
fix to distutils dependencies syntaxrelease_4_1_16b_tag
-rw-r--r--CHANGES1
-rw-r--r--setup.py4
2 files changed, 3 insertions, 2 deletions
diff --git a/CHANGES b/CHANGES
index 08de7ce..4e1824a 100644
--- a/CHANGES
+++ b/CHANGES
@@ -6,6 +6,7 @@ Revision 4.1.16b
when responding to a v1 Manager.
- Fix to state information handling at CommandResponder app.
- Fix to Twisted reactor shutdown condition.
+- Fix to distutils dependencies syntax.
Revision 4.1.16a
----------------
diff --git a/setup.py b/setup.py
index 14f4f34..45c9aa8 100644
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,7 @@ It's very easy to install it, just type (as root on Linux):
try:
from setuptools import setup
params = {
- 'install_requires': [ 'pyasn1>=0.0.13a', 'pycrypto' ],
+ 'install_requires': [ 'pyasn1>=0.0.13', 'pycrypto' ],
'zip_safe': True
}
except ImportError:
@@ -24,7 +24,7 @@ except ImportError:
from distutils.core import setup
if sys.version_info > (2, 2):
params = {
- 'requires': [ 'pyasn1>=0.0.13a', 'pycrypto' ]
+ 'requires': [ 'pyasn1(>=0.0.13)', 'pycrypto' ]
}
else:
params = {}