summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorelie <elie>2013-01-06 21:20:00 +0000
committerelie <elie>2013-01-06 21:20:00 +0000
commitd577741cc42cb49760b32f83153ecd60cbad8fe2 (patch)
tree23c5c934120b5fb414ec7bc68b64acd57743284c
parent015a2307ba77e9498c1b3dcd83f95c0c47cd4bb8 (diff)
downloadpysnmp-release_4_2_4_tag.tar.gz
use platform-neutral pathsrelease_4_2_4_tag
-rw-r--r--setup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 67d0903..610fd82 100644
--- a/setup.py
+++ b/setup.py
@@ -1,11 +1,12 @@
#!/usr/bin/env python
-"""SNMP framework
+"""SNMP library for Python
SNMP v1/v2c/v3 engine and apps written in pure-Python.
Supports Manager/Agent/Proxy roles, scriptable MIBs,
asynchronous operation and multiple transports.
"""
import sys
+import os
classifiers = """\
Development Status :: 5 - Production/Stable
@@ -89,7 +90,7 @@ doclines = [ x.strip() for x in __doc__.split('\n') if x ]
params.update( {
'name': 'pysnmp',
- 'version': open('pysnmp/__init__.py').read().split('\'')[1],
+ 'version': open(os.path.join('pysnmp','__init__.py')).read().split('\'')[1],
'description': doclines[0],
'long_description': ' '.join(doclines[1:]),
'maintainer': 'Ilya Etingof <ilya@glas.net>',
@@ -125,7 +126,8 @@ params.update( {
'pysnmp.proto.acmod',
'pysnmp.proto.proxy',
'pysnmp.proto.api' ],
- 'scripts': [ 'tools/libsmi2pysnmp', 'tools/build-pysnmp-mib' ]
+ 'scripts': [ os.path.join('tools','libsmi2pysnmp'),
+ os.path.join('tools', 'build-pysnmp-mib') ]
} )
setup(**params)