summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorelie <elie>2012-04-27 11:04:28 +0000
committerelie <elie>2012-04-27 11:04:28 +0000
commit8d8b8cd8dfa66b67d579f7e8c78ef149f10512ba (patch)
treeea7e659da0e3bb19bc99016485af7abc7f8a05f6
parentac1fe67e09366e8db7723c5b7052d1dc33220cc6 (diff)
downloadpysnmp-8d8b8cd8dfa66b67d579f7e8c78ef149f10512ba.tar.gz
fix to libsmi2pysnmp tool to make it working again in Python < 2.7
-rw-r--r--CHANGES5
-rw-r--r--setup.py2
-rw-r--r--tools/libsmi2pysnmp4
3 files changed, 8 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 40f6917..28133b9 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,8 @@
+Revision 4.2.3
+--------------
+
+- Fix to libsmi2pysnmp tool to make it working again in Python < 2.7
+
Revision 4.2.2
--------------
diff --git a/setup.py b/setup.py
index ba25db4..a3a5bd2 100644
--- a/setup.py
+++ b/setup.py
@@ -42,7 +42,7 @@ and install into your system.
params.update( {
'name': 'pysnmp',
- 'version': '4.2.2',
+ 'version': '4.2.3',
'description': 'SNMP framework',
'author': 'Ilya Etingof',
'author_email': 'ilya@glas.net',
diff --git a/tools/libsmi2pysnmp b/tools/libsmi2pysnmp
index 50ebd85..caf6700 100644
--- a/tools/libsmi2pysnmp
+++ b/tools/libsmi2pysnmp
@@ -357,11 +357,11 @@ if 'typedefs' in mib:
while len(typedefs_left):
delayed = []
for t in typedefs_left:
- if t[1]['parent module']['name'] in { \
+ if t[1]['parent module']['name'] in ( \
# implicitly imported MIBs
'SNMPv2-TC',
'SNMPv2-SMI'
- } or t[1]['parent module']['type'] in typedefs_seen:
+ ) or t[1]['parent module']['type'] in typedefs_seen:
typedefs_seen.add(t[0])
typedefs.append(t)
continue