summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorelie <elie>2008-02-05 20:12:22 +0000
committerelie <elie>2008-02-05 20:12:22 +0000
commit961ffda749f6e67f97579bff9c986d3b011c0fa4 (patch)
treeac8190185a5283271c97a54e78f5f707a385e005
parented4983d8ee63e59f4de57820ac738403dfc87cac (diff)
downloadpysnmp-961ffda749f6e67f97579bff9c986d3b011c0fa4.tar.gz
updated
-rw-r--r--CHANGES11
-rw-r--r--README9
-rw-r--r--setup.py2
3 files changed, 15 insertions, 7 deletions
diff --git a/CHANGES b/CHANGES
index dc3bd4c..9efeb11 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,14 +1,21 @@
-Revision 4.1.9b
----------------
+Revision 4.1.10a
+----------------
- Internal MIB indexing method __indexMib() unmangled to facilitate
setting up mutex there for sharing MIB stuff between threads.
- Fixed broken IpAddress value handling in SET operation.
+- Broken MibBuilder.unloadModules() method now works.
- Use getLabel() SMI object method when building MIB tree (in builder.py)
in addition to direct attribute access for clearer object protocol.
+- The MIB building tools updated to match significantly improved
+ smidump tool (libsmi version > 0.4.5).
- Made libsmi2pysnmp tool optionally building MIB text fields into pysnmp
MIB code (enabled by default) and MibBuilder conditionally loading them
up (disabled by default).
+- SnmpEngine and MsgAndPduDispatcher constructors now optionally
+ take msgAndPduDspr and mibInstrumController class instances
+ respectively to facilitate these objects sharing within a process.
+- Built-in MIBs re-generated to include text fields.
Revision 4.1.9a
---------------
diff --git a/README b/README
index 13fd291..d920a77 100644
--- a/README
+++ b/README
@@ -100,12 +100,11 @@ visualisation purposes (SNMP manager side) and/or become management targets
While MIB parser/codegenerator has not been implemented in PySNMP, the
smidump tool of libsmi library [6] could be used for automatic convertion
-of MIB text files into Python code. The code been generated relies upon
-PySNMP SMI library.
+of MIB text files into Python code. The produced code relies on PySNMP
+SMI library.
In order to convert MIB text files into pysnmp.smi-compliant Python source,
-please, use build-pysnmp-mib utility as shipped along with PySNMP
-distribution.
+please, use build-pysnmp-mib utility as shipped with PySNMP distribution.
A large set of pre-compiled MIB files is shipped along the pysnmp-mibs
package.[2]
@@ -150,6 +149,8 @@ REFERENCES
[6] libsmi homepage
http://www.ibr.cs.tu-bs.de/projects/libsmi/
+ Use libsmi version > 0.4.5, possibly from libsmi SVN:
+ svn checkout http://www.ibr.cs.tu-bs.de/svn/libsmi
[7] PySNMP mailing list archives:
http://sourceforge.net/mail/?group_id=14735
diff --git a/setup.py b/setup.py
index bada931..0eab59b 100644
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,7 @@
from distutils.core import setup
setup(name="pysnmp",
- version="4.1.9b",
+ version="4.1.10a",
description="SNMP framework for Python",
author="Ilya Etingof",
author_email="ilya@glas.net ",