summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2010-07-08 21:12:50 +0000
committerelie <elie>2010-07-08 21:12:50 +0000
commit2689deb812a7e75476f56867062e11db9acc3838 (patch)
tree4690cbe1c13a0c977e5cebf7673214c6496e8229 /setup.py
parentc09cb9b40cffc13d1d2e6c33e10a559d7f304f2e (diff)
downloadpysnmp-2689deb812a7e75476f56867062e11db9acc3838.tar.gz
fix to egg detection
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3ae3680..df7973f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
#!/usr/bin/env python
import sys
+import string
def howto_install_setuptools():
print """Error: You need setuptools Python package!
@@ -13,7 +14,7 @@ try:
from setuptools import setup
except ImportError:
for arg in sys.argv:
- if "egg" in arg:
+ if string.find(arg, 'egg') == -1:
howto_install_setuptools()
sys.exit(1)
from distutils.core import setup