summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2015-09-27 10:26:25 +0000
committerelie <elie>2015-09-27 10:26:25 +0000
commit627d9ff4a3715477e56fe397f099ad0db0d5c1b9 (patch)
tree60cdd6f446e892194122abad0dfa4c6413eb4374 /setup.py
parentbdfbce73382678e0288d8bc8d3093c827b05e1d1 (diff)
downloadpysnmp-627d9ff4a3715477e56fe397f099ad0db0d5c1b9.tar.gz
* Asyncore and asyncio-based APIs reworked to become functions.
* Asyncio and Twisted API moved entirely into high-level domain to be aligned with other high-level APIs. This WILL BREAK backward compatibility for those apps that use Twisted API.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7f189ad..4cf6cbe 100644
--- a/setup.py
+++ b/setup.py
@@ -104,12 +104,14 @@ params.update( {
'pysnmp.carrier.asyncio.dgram',
'pysnmp.entity',
'pysnmp.entity.rfc3413',
- 'pysnmp.entity.rfc3413.twisted',
- 'pysnmp.entity.rfc3413.asyncio',
+ 'pysnmp.entity.rfc3413.oneliner',
'pysnmp.hlapi',
+ 'pysnmp.hlapi.asyncio',
'pysnmp.hlapi.asyncore',
'pysnmp.hlapi.asyncore._sync',
'pysnmp.hlapi.asyncore._sync.compat',
+ 'pysnmp.hlapi.trollius',
+ 'pysnmp.hlapi.twisted',
'pysnmp.proto',
'pysnmp.proto.mpmod',
'pysnmp.proto.secmod',