summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2013-09-21 10:10:34 +0000
committerelie <elie>2013-09-21 10:10:34 +0000
commit83b865fc53f0435a4c5c12a314c416cca1b6b058 (patch)
treef75377803d4558a0f90817cba2c76a4d7ff13e67 /setup.py
parent0ee047438ce8aaa947e295a08f3a6c99dfa01701 (diff)
downloadpysnmp-83b865fc53f0435a4c5c12a314c416cca1b6b058.tar.gz
Python 2.4+ installation requirement added
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 88893df..a6a1081 100644
--- a/setup.py
+++ b/setup.py
@@ -40,6 +40,10 @@ def howto_install_setuptools():
Then you could make eggs from this package.
""")
+if sys.version_info[:2] < (2, 4):
+ print("ERROR: this package requires Python 2.4 or later!")
+ sys.exit(1)
+
try:
from setuptools import setup
params = {