summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorelie <elie>2011-11-06 20:37:09 +0000
committerelie <elie>2011-11-06 20:37:09 +0000
commitc239eaf23775c4149623d726f1d61be31c0c40b2 (patch)
tree153d0d2788dd840b1729dccbbde69ff63bcac2b1 /setup.py
parent42d5c35838a0726fd60683080e5677a76719ef2f (diff)
downloadpysnmp-c239eaf23775c4149623d726f1d61be31c0c40b2.tar.gz
major overhawl aimed at Python 2.4 through 3.2 compatibility
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 23 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index c729e2b..0a18919 100644
--- a/setup.py
+++ b/setup.py
@@ -1,41 +1,52 @@
#!/usr/bin/env python
import sys
-import string
def howto_install_setuptools():
- print """Error: You need setuptools Python package!
+ print("""Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
wget http://peak.telecommunity.com/dist/ez_setup.py
python ez_setup.py
-"""
+""")
try:
from setuptools import setup
params = {
- 'install_requires': [ 'pyasn1>=0.0.13', 'pycrypto' ],
+ 'install_requires': [ 'pyasn1>=0.0.14', 'pycrypto>=2.3' ],
'zip_safe': True
}
except ImportError:
for arg in sys.argv:
- if string.find(arg, 'egg') != -1:
+ if arg.find('egg') != -1:
howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
- if sys.version_info > (2, 2):
- params = {
- 'requires': [ 'pyasn1(>=0.0.13)', 'pycrypto' ]
+ params = {
+ 'requires': [ 'pyasn1(>=0.0.14)', 'pycrypto(>=2.3)' ]
}
- else:
- params = {}
params.update( {
'name': 'pysnmp',
- 'version': '4.1.16d',
+ 'version': '4.2.1',
'description': 'SNMP framework',
'author': 'Ilya Etingof',
'author_email': 'ilya@glas.net',
'url': 'http://sourceforge.net/projects/pysnmp/',
+ 'classifiers': [
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'Intended Audience :: Telecommunications Industry',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Security',
+ 'Topic :: Communications',
+ 'Topic :: System :: Monitoring',
+ 'Topic :: System :: Networking :: Monitoring',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'License :: OSI Approved :: BSD License'
+ ],
'license': 'BSD',
'packages': [ 'pysnmp',
'pysnmp.smi',
@@ -66,5 +77,4 @@ params.update( {
'scripts': [ 'tools/libsmi2pysnmp', 'tools/build-pysnmp-mib' ]
} )
-apply(setup, (), params)
-
+setup(**params)