summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES1
-rw-r--r--setup.py21
2 files changed, 4 insertions, 18 deletions
diff --git a/CHANGES b/CHANGES
index 449ac7c..7123930 100644
--- a/CHANGES
+++ b/CHANGES
@@ -35,6 +35,7 @@ Revision 4.2.5rc2
receiver ID token to be used by transport dispatcher's data router. This
allows for multiple SNMP engines registration with a single transport
dispatcher.
+- Distribute is gone, switched to setuptools completely.
- The snmpCommunityTable row selection improved to follow RFC2576, clause
5.2.1.
- Asyncore-based dispatcher attempts to use poll() whenever available
diff --git a/setup.py b/setup.py
index 610fd82..88893df 100644
--- a/setup.py
+++ b/setup.py
@@ -28,25 +28,13 @@ Topic :: System :: Networking :: Monitoring
Topic :: Software Development :: Libraries :: Python Modules
"""
-def howto_install_distribute():
- print("""
- Error: You need the distribute Python package!
-
- It's very easy to install it, just type (as root on Linux):
-
- wget http://python-distribute.org/distribute_setup.py
- python distribute_setup.py
-
- Then you could make eggs from this package.
-""")
-
def howto_install_setuptools():
print("""
Error: You need setuptools Python package!
It's very easy to install it, just type (as root on Linux):
- wget http://peak.telecommunity.com/dist/ez_setup.py
+ wget https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py
python ez_setup.py
Then you could make eggs from this package.
@@ -63,11 +51,8 @@ try:
except ImportError:
for arg in sys.argv:
- if arg.find('egg') != -1:
- if sys.version_info[0] > 2:
- howto_install_distribute()
- else:
- howto_install_setuptools()
+ if 'egg' in arg:
+ howto_install_setuptools()
sys.exit(1)
from distutils.core import setup
params = {}